aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2018-01-14 22:38:54 +0800
committerJeffery To <jeffery.to@gmail.com>2018-01-15 01:33:01 +0800
commit64ae3625e13613e21446a8d6e3fdc236a99b708a (patch)
treecdc69f413adcc84535ed184f79312c25c974ae1c
parentf460719bf4556e095ca3c21f204079d356f2900a (diff)
python-*,python3-*: add src packages for multiple packages
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python-attrs/Makefile4
-rw-r--r--lang/python/python-cryptography/Makefile5
-rw-r--r--lang/python/python-idna/Makefile7
-rw-r--r--lang/python/python-parsley/Makefile4
-rw-r--r--lang/python/python-ply/Makefile6
-rw-r--r--lang/python/python-pyasn1-modules/Makefile5
-rw-r--r--lang/python/python-pyasn1/Makefile5
-rw-r--r--lang/python/python-pycparser/Makefile4
-rw-r--r--lang/python/python-pyopenssl/Makefile5
-rw-r--r--lang/python/python-service-identity/Makefile4
-rw-r--r--lang/python/python-six/Makefile7
-rw-r--r--lang/python/python-zope-interface/Makefile4
12 files changed, 45 insertions, 15 deletions
diff --git a/lang/python/python-attrs/Makefile b/lang/python/python-attrs/Makefile
index 3911a1d34..8430eeeb4 100644
--- a/lang/python/python-attrs/Makefile
+++ b/lang/python/python-attrs/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-attrs
PKG_VERSION:=17.4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=attrs-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/8b/0b/a06cfcb69d0cb004fde8bc6f0fd192d96d565d1b8aa2829f0f20adb796e5
@@ -62,6 +62,8 @@ endef
$(eval $(call PyPackage,python-attrs))
$(eval $(call BuildPackage,python-attrs))
+$(eval $(call BuildPackage,python-attrs-src))
$(eval $(call Py3Package,python3-attrs))
$(eval $(call BuildPackage,python3-attrs))
+$(eval $(call BuildPackage,python3-attrs-src))
diff --git a/lang/python/python-cryptography/Makefile b/lang/python/python-cryptography/Makefile
index 73064d396..02e95dabc 100644
--- a/lang/python/python-cryptography/Makefile
+++ b/lang/python/python-cryptography/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-cryptography
PKG_VERSION:=2.1.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=cryptography-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/78/c5/7188f15a92413096c93053d5304718e1f6ba88b818357d05d19250ebff85
@@ -75,5 +75,8 @@ endef
$(eval $(call PyPackage,python-cryptography))
$(eval $(call BuildPackage,python-cryptography))
+$(eval $(call BuildPackage,python-cryptography-src))
+
$(eval $(call Py3Package,python3-cryptography))
$(eval $(call BuildPackage,python3-cryptography))
+$(eval $(call BuildPackage,python3-cryptography-src))
diff --git a/lang/python/python-idna/Makefile b/lang/python/python-idna/Makefile
index d5af7d39d..47f4b9668 100644
--- a/lang/python/python-idna/Makefile
+++ b/lang/python/python-idna/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015-2016 OpenWrt.org
+# Copyright (C) 2015-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-idna
PKG_VERSION:=2.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=idna-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/f4/bd/0467d62790828c23c47fc1dfa1b1f052b24efdf5290f071c7a91d0d82fd3
@@ -63,5 +63,8 @@ endef
$(eval $(call PyPackage,python-idna))
$(eval $(call BuildPackage,python-idna))
+$(eval $(call BuildPackage,python-idna-src))
+
$(eval $(call Py3Package,python3-idna))
$(eval $(call BuildPackage,python3-idna))
+$(eval $(call BuildPackage,python3-idna-src))
diff --git a/lang/python/python-parsley/Makefile b/lang/python/python-parsley/Makefile
index ab915ac32..53b50954c 100644
--- a/lang/python/python-parsley/Makefile
+++ b/lang/python/python-parsley/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-parsley
PKG_VERSION:=1.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=Parsley-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/source/P/Parsley
@@ -68,6 +68,8 @@ endef
$(eval $(call PyPackage,python-parsley))
$(eval $(call BuildPackage,python-parsley))
+$(eval $(call BuildPackage,python-parsley-src))
$(eval $(call Py3Package,python3-parsley))
$(eval $(call BuildPackage,python3-parsley))
+$(eval $(call BuildPackage,python3-parsley-src))
diff --git a/lang/python/python-ply/Makefile b/lang/python/python-ply/Makefile
index 1d42831a1..697020402 100644
--- a/lang/python/python-ply/Makefile
+++ b/lang/python/python-ply/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015-2016 OpenWrt.org
+# Copyright (C) 2015-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-ply
PKG_VERSION:=3.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=ply-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.dabeaz.com/ply
@@ -61,6 +61,8 @@ endef
$(eval $(call PyPackage,python-ply))
$(eval $(call BuildPackage,python-ply))
+$(eval $(call BuildPackage,python-ply-src))
$(eval $(call Py3Package,python3-ply))
$(eval $(call BuildPackage,python3-ply))
+$(eval $(call BuildPackage,python3-ply-src))
diff --git a/lang/python/python-pyasn1-modules/Makefile b/lang/python/python-pyasn1-modules/Makefile
index 1407053c3..7ad1e1f35 100644
--- a/lang/python/python-pyasn1-modules/Makefile
+++ b/lang/python/python-pyasn1-modules/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-pyasn1-modules
PKG_VERSION:=0.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=pyasn1-modules-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/ab/76/36ab0e099e6bd27ed95b70c2c86c326d3affa59b9b535c63a2f892ac9f45
@@ -65,5 +65,8 @@ endef
$(eval $(call PyPackage,python-pyasn1-modules))
$(eval $(call BuildPackage,python-pyasn1-modules))
+$(eval $(call BuildPackage,python-pyasn1-modules-src))
+
$(eval $(call Py3Package,python3-pyasn1-modules))
$(eval $(call BuildPackage,python3-pyasn1-modules))
+$(eval $(call BuildPackage,python3-pyasn1-modules-src))
diff --git a/lang/python/python-pyasn1/Makefile b/lang/python/python-pyasn1/Makefile
index 5b002eeeb..6129f3d43 100644
--- a/lang/python/python-pyasn1/Makefile
+++ b/lang/python/python-pyasn1/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-pyasn1
PKG_VERSION:=0.4.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=pyasn1-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/eb/3d/b7d0fdf4a882e26674c68c20f40682491377c4db1439870f5b6f862f76ed
@@ -63,5 +63,8 @@ endef
$(eval $(call PyPackage,python-pyasn1))
$(eval $(call BuildPackage,python-pyasn1))
+$(eval $(call BuildPackage,python-pyasn1-src))
+
$(eval $(call Py3Package,python3-pyasn1))
$(eval $(call BuildPackage,python3-pyasn1))
+$(eval $(call BuildPackage,python3-pyasn1-src))
diff --git a/lang/python/python-pycparser/Makefile b/lang/python/python-pycparser/Makefile
index 7bdad5cc8..9a8b65cae 100644
--- a/lang/python/python-pycparser/Makefile
+++ b/lang/python/python-pycparser/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-pycparser
PKG_VERSION:=2.18
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=pycparser-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/8c/2d/aad7f16146f4197a11f8e91fb81df177adcc2073d36a17b1491fd09df6ed
@@ -65,6 +65,8 @@ endef
$(eval $(call PyPackage,python-pycparser))
$(eval $(call BuildPackage,python-pycparser))
+$(eval $(call BuildPackage,python-pycparser-src))
$(eval $(call Py3Package,python3-pycparser))
$(eval $(call BuildPackage,python3-pycparser))
+$(eval $(call BuildPackage,python3-pycparser-src))
diff --git a/lang/python/python-pyopenssl/Makefile b/lang/python/python-pyopenssl/Makefile
index f07b2b2e3..3f8fc9058 100644
--- a/lang/python/python-pyopenssl/Makefile
+++ b/lang/python/python-pyopenssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-pyopenssl
PKG_VERSION:=17.5.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=pyOpenSSL-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/3b/15/a5d90ab1a41075e8f0fae334f13452549528f82142b3b9d0c9d86ab7178c
@@ -66,5 +66,8 @@ endef
$(eval $(call PyPackage,python-pyopenssl))
$(eval $(call BuildPackage,python-pyopenssl))
+$(eval $(call BuildPackage,python-pyopenssl-src))
+
$(eval $(call Py3Package,python3-pyopenssl))
$(eval $(call BuildPackage,python3-pyopenssl))
+$(eval $(call BuildPackage,python3-pyopenssl-src))
diff --git a/lang/python/python-service-identity/Makefile b/lang/python/python-service-identity/Makefile
index e1ce42f2e..552ba3d31 100644
--- a/lang/python/python-service-identity/Makefile
+++ b/lang/python/python-service-identity/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-service-identity
PKG_VERSION:=17.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=service_identity-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/de/2a/cab6e30be82c8fcd2339ef618036720eda954cf05daef514e386661c9221
@@ -71,6 +71,8 @@ endef
$(eval $(call PyPackage,python-service-identity))
$(eval $(call BuildPackage,python-service-identity))
+$(eval $(call BuildPackage,python-service-identity-src))
$(eval $(call Py3Package,python3-service-identity))
$(eval $(call BuildPackage,python3-service-identity))
+$(eval $(call BuildPackage,python3-service-identity-src))
diff --git a/lang/python/python-six/Makefile b/lang/python/python-six/Makefile
index e59784064..2e7e4fa5b 100644
--- a/lang/python/python-six/Makefile
+++ b/lang/python/python-six/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015, 2017-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-six
PKG_VERSION:=1.11.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=six-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/16/d8/bc6316cf98419719bd59c91742194c111b6f2e85abac88e496adefaf7afe
@@ -75,5 +75,8 @@ $(eval $(call HostBuild))
$(eval $(call PyPackage,python-six))
$(eval $(call BuildPackage,python-six))
+$(eval $(call BuildPackage,python-six-src))
+
$(eval $(call Py3Package,python3-six))
$(eval $(call BuildPackage,python3-six))
+$(eval $(call BuildPackage,python3-six-src))
diff --git a/lang/python/python-zope-interface/Makefile b/lang/python/python-zope-interface/Makefile
index b78893cc2..42e248ae5 100644
--- a/lang/python/python-zope-interface/Makefile
+++ b/lang/python/python-zope-interface/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-zope-interface
PKG_VERSION:=4.4.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=zope.interface-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/bd/d2/25349ed41f9dcff7b3baf87bd88a4c82396cf6e02f1f42bb68657a3132af
@@ -75,6 +75,8 @@ endef
$(eval $(call PyPackage,python-zope-interface))
$(eval $(call BuildPackage,python-zope-interface))
+$(eval $(call BuildPackage,python-zope-interface-src))
$(eval $(call Py3Package,python3-zope-interface))
$(eval $(call BuildPackage,python3-zope-interface))
+$(eval $(call BuildPackage,python3-zope-interface-src))