aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-02-29 13:57:40 -0800
committerRosen Penev <rosenp@gmail.com>2020-03-03 11:38:46 -0800
commit647bacd46bda15d50e2d3f30dc70cbebb69029cb (patch)
tree457bd54f99ce26c3ffa234c17cf21d90ebc313e1
parent1ebecd31ab3d5438fa6b23186d2021026affaa26 (diff)
linknx: convert to procd
Removed options UCI parameter. It's not terribly useful. Most of the parameters can be replaced with procd functionality. procd also demands processes to run in the foreground. Removed -fno-builtin. It seems to be a legacy option. Ran init script through shellcheck. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--net/linknx/Makefile5
-rw-r--r--net/linknx/files/linknx.config7
-rw-r--r--net/linknx/files/linknx.init20
3 files changed, 14 insertions, 18 deletions
diff --git a/net/linknx/Makefile b/net/linknx/Makefile
index ed4fd4811..6fee40dfa 100644
--- a/net/linknx/Makefile
+++ b/net/linknx/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=linknx
PKG_VERSION:=0.0.1.37
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-${PKG_VERSION}.tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/linknx/linknx/tar.gz/$(PKG_VERSION)?
@@ -42,9 +42,6 @@ CONFIGURE_ARGS+= \
--with-libcurl \
--without-mysql
-EXTRA_LDFLAGS+= \
- -fno-builtin
-
define Package/linknx/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/linknx $(1)/usr/bin/
diff --git a/net/linknx/files/linknx.config b/net/linknx/files/linknx.config
index d2f05628f..f3b60f39d 100644
--- a/net/linknx/files/linknx.config
+++ b/net/linknx/files/linknx.config
@@ -1,8 +1,3 @@
-config daemon args
- # daemon is started as 'linknx --config=$conf $options'
- # use 'linknx --help' to get all possible options'
- #
- # typical example
+config args
option conf '/etc/linknx.xml'
- option options '-w --daemon=/tmp/linknx/linknx.log --pid-file=/var/run/linknx.pid'
diff --git a/net/linknx/files/linknx.init b/net/linknx/files/linknx.init
index d38f194db..27b2c4b80 100644
--- a/net/linknx/files/linknx.init
+++ b/net/linknx/files/linknx.init
@@ -3,21 +3,25 @@
START=98
STOP=10
+USE_PROCD=1
NAME=linknx
PROG=/usr/bin/$NAME
. /lib/functions.sh
-start() {
- local conf options
+start_service() {
+ local conf
config_load "$NAME"
config_get conf args conf '/etc/linknx.xml'
- config_get options args options ''
- test -f $conf || cp -p /etc/linknx.xml.dist $conf
+ [ -f "$conf" ] || cp -p /etc/linknx.xml.dist "$conf"
mkdir -p /tmp/$NAME/persist
- service_start $PROG --config=$conf $options
-}
-stop() {
- service_stop $PROG
+ procd_open_instance
+ procd_set_param command "$PROG"
+ procd_append_param command --config="$conf" -w
+ procd_set_param file "$conf"
+ procd_set_param pidfile /var/run/linknx.pid
+ procd_set_param stdout 1
+ procd_set_param stderr 1
+ procd_close_instance
}