aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Baier <jan.baier@amagical.net>2021-08-16 12:19:46 +0200
committerEtienne Champetier <champetier.etienne@gmail.com>2021-08-18 10:37:40 -0400
commit641f75d98ac77139d44056d260395efea169abf7 (patch)
tree0880fcb1a64120532bada558c01618941223d3f9
parent1cba8af1b1eb4b499488534164cd3d41b33026ea (diff)
zabbix: Call killall with the -s
Some versions of killall do support the `killall -SIGNAL` syntax and have only `-s SIGNAL` which should be supported everywhere. I see the problem with *killall (PSmisc) 23.3* on latest TurrisOS 5.2 Signed-off-by: Jan Baier <jan.baier@amagical.net>
-rw-r--r--admin/zabbix/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/admin/zabbix/Makefile b/admin/zabbix/Makefile
index 53fc65291..f4d3fafc0 100644
--- a/admin/zabbix/Makefile
+++ b/admin/zabbix/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zabbix
PKG_VERSION:=5.0.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://cdn.zabbix.com/zabbix/sources/stable/5.0/
@@ -266,7 +266,7 @@ endef
define Package/zabbix-extra-network/postinst
#!/bin/sh
if [ -z "$${IPKG_INSTROOT}" ]; then
- killall -HUP ubusd
+ killall -s HUP ubusd
fi
endef
@@ -279,7 +279,7 @@ endef
define Package/zabbix-extra-wifi/postinst
#!/bin/sh
if [ -z "$${IPKG_INSTROOT}" ]; then
- killall -HUP ubusd
+ killall -s HUP ubusd
fi
endef