aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2015-06-18 15:06:29 -0400
committerTed Hess <thess@kitschensync.net>2015-06-18 15:06:29 -0400
commit63fa44476d4510d9686d331fab8d8132f1d06ae4 (patch)
treec0fbb841951cbd9b37b325fcd6a6a94674c47e70
parentdb2eba4dc4f6958889f8664837c8c477f9808c6a (diff)
mocp: Fix musl compatibility
Signed-off-by: Ted Hess <thess@kitschensync.net>
-rw-r--r--sound/mocp/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/sound/mocp/Makefile b/sound/mocp/Makefile
index 5552ec962..d1917bfbe 100644
--- a/sound/mocp/Makefile
+++ b/sound/mocp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=moc
PKG_VERSION:=2.5.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ftp.daper.net/pub/soft/moc/stable/
@@ -38,6 +38,8 @@ define Package/moc/description
MOC (music on console) is a console audio player for LINUX/UNIX designed to be powerful and easy to use.
endef
+TARGET_CFLAGS+=-D_GNU_SOURCE
+
define Build/Configure
$(call Build/Configure/Default, \
$(if $(CONFIG_BUILD_PATENTED),,--without-mp3) \