aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-03-17 19:45:22 -0700
committerRosen Penev <rosenp@gmail.com>2019-03-17 21:12:43 -0700
commit63bffa084944ca1ee66a1fd74484a1afe1998367 (patch)
treed89d351a9a25bf0525cbff5161f53a4300c8c474
parentdc08c3b9e90d9a3c586aa9c58fc59612763534fd (diff)
gst1-plugins-good: Disable debug and other fixes
Added PKG_BUILD_PARALLEL for faster compilation. Removed rpath hack as it is no longer necessary. Removed old patches that are now handled by configure flags. Signed-off-by: Rosen Penev <rosenp@gmail.com>
3 files changed, 12 insertions, 67 deletions
diff --git a/multimedia/gst1-plugins-good/Makefile b/multimedia/gst1-plugins-good/Makefile
index 2152e57a0..729972215 100644
--- a/multimedia/gst1-plugins-good/Makefile
+++ b/multimedia/gst1-plugins-good/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gst1-plugins-good
PKG_VERSION:=1.15.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
Ted Hess <thess@kitschensync.net>
@@ -27,6 +27,7 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_gst1-mod-mpg123 \
PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@@ -97,8 +98,15 @@ CONFIGURE_ARGS += \
$(call GST_COND_SELECT,lame) \
$(call GST_COND_SELECT,mpg123) \
\
+ --disable-Bsymbolic \
--disable-debug \
--disable-examples \
+ --disable-fatal-warnings \
+ --disable-glib-asserts \
+ --disable-gobject-cast-checks \
+ --disable-gtk-doc-html \
+ --disable-rpath \
+ --disable-valgrind \
\
--disable-aalib \
--disable-annodex \
@@ -127,16 +135,10 @@ CONFIGURE_ARGS += \
--disable-y4m \
--disable-zlib \
\
+ --without-gudev \
+ --without-libv4l2 \
--without-libiconv-prefix \
- --without-libintl-prefix \
- --without-x \
-
-TARGET_CFLAGS += -Wno-incompatible-pointer-types
-
-EXTRA_LDFLAGS+= \
- -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
- $(if $(ICONV_FULL),-liconv) \
-
+ --without-libintl-prefix
define Package/gst1-plugins-good/install
/bin/true
diff --git a/multimedia/gst1-plugins-good/patches/002-no-tests.patch b/multimedia/gst1-plugins-good/patches/002-no-tests.patch
deleted file mode 100644
index de2294879..000000000
--- a/multimedia/gst1-plugins-good/patches/002-no-tests.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -2,7 +2,6 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
-
- ALWAYS_SUBDIRS = \
- gst sys ext \
-- tests \
- docs \
- common \
- m4 \
---- a/configure.ac
-+++ b/configure.ac
-@@ -1292,22 +1292,6 @@ sys/osxvideo/Makefile
- sys/v4l2/Makefile
- sys/waveform/Makefile
- sys/ximage/Makefile
--tests/Makefile
--tests/check/Makefile
--tests/examples/Makefile
--tests/examples/audiofx/Makefile
--tests/examples/cairo/Makefile
--tests/examples/equalizer/Makefile
--tests/examples/gtk/Makefile
--tests/examples/jack/Makefile
--tests/examples/level/Makefile
--tests/examples/rtp/Makefile
--tests/examples/rtsp/Makefile
--tests/examples/shapewipe/Makefile
--tests/examples/spectrum/Makefile
--tests/examples/v4l2/Makefile
--tests/files/Makefile
--tests/icles/Makefile
- common/Makefile
- common/m4/Makefile
- m4/Makefile
diff --git a/multimedia/gst1-plugins-good/patches/003-no-docs.patch b/multimedia/gst1-plugins-good/patches/003-no-docs.patch
deleted file mode 100644
index f96205936..000000000
--- a/multimedia/gst1-plugins-good/patches/003-no-docs.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -2,7 +2,6 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
-
- ALWAYS_SUBDIRS = \
- gst sys ext \
-- docs \
- common \
- m4 \
- pkgconfig
---- a/configure.ac
-+++ b/configure.ac
-@@ -1295,9 +1295,6 @@ sys/ximage/Makefile
- common/Makefile
- common/m4/Makefile
- m4/Makefile
--docs/Makefile
--docs/plugins/Makefile
--docs/version.entities
- pkgconfig/Makefile
- pkgconfig/gstreamer-plugins-good-uninstalled.pc
- )