aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2022-12-19 19:17:14 -0600
committerRosen Penev <rosenp@gmail.com>2022-12-22 16:28:45 -0800
commit63816dab84b55ea24728dee5bd05d26b7a70a889 (patch)
treee4af43b59442a04bba1b495e78b3fb45d2868f22
parent72f683ec273c4b24ccf4951c4b408279a60bcdf7 (diff)
quota: update to 4.09
Signed-off-by: W. Michael Petullo <mike@flyn.org>
-rw-r--r--utils/quota/Makefile4
-rw-r--r--utils/quota/patches/010-cdefs.patch18
-rw-r--r--utils/quota/patches/020-remove-reallocarray.patch11
3 files changed, 2 insertions, 31 deletions
diff --git a/utils/quota/Makefile b/utils/quota/Makefile
index 74b59429c..bb844173a 100644
--- a/utils/quota/Makefile
+++ b/utils/quota/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=quota
-PKG_VERSION:=4.06
+PKG_VERSION:=4.09
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/linuxquota
-PKG_HASH:=2f3e03039f378d4f0d97acdb49daf581dcaad64d2e1ddf129495fd579fbd268d
+PKG_HASH:=9cdaca154bc92afc3117f0e5f5b3208dd5f84583af1cf061c39baa0a2bb142f9
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
PKG_LICENSE:=GPL-2.0-or-later
diff --git a/utils/quota/patches/010-cdefs.patch b/utils/quota/patches/010-cdefs.patch
deleted file mode 100644
index a44978e7e..000000000
--- a/utils/quota/patches/010-cdefs.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/quota.h
-+++ b/quota.h
-@@ -1,7 +1,6 @@
- #ifndef GUARD_QUOTA_H
- #define GUARD_QUOTA_H
-
--#include <sys/cdefs.h>
- #include <sys/types.h>
- #include <stdint.h>
-
-@@ -182,6 +181,6 @@ enum {
- #endif
- #endif
-
--long quotactl __P((int, const char *, qid_t, caddr_t));
-+long quotactl (int, const char *, qid_t, caddr_t);
-
- #endif /* _QUOTA_ */
diff --git a/utils/quota/patches/020-remove-reallocarray.patch b/utils/quota/patches/020-remove-reallocarray.patch
deleted file mode 100644
index 75c7a5d9b..000000000
--- a/utils/quota/patches/020-remove-reallocarray.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/quota.c
-+++ b/quota.c
-@@ -385,7 +385,7 @@ int main(int argc, char **argv)
- break;
- case 259:
- fscount++;
-- fsnames = reallocarray(fsnames, fscount, sizeof(char *));
-+ fsnames = realloc(fsnames, fscount * sizeof(char *));
- if (!fsnames)
- die(1, _("Not enough memory for filesystem names"));
- fsnames[fscount - 1] = optarg;