aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Pavlov <AuthorReflex@gmail.com>2022-08-25 22:39:47 +0300
committerRosen Penev <rosenp@gmail.com>2022-08-31 13:32:56 -0700
commit62e909e845e25ea87d671358cc8f4724326c7eaf (patch)
tree0b5460c3cda0c87ce797ff5107ff77f0c20f03fd
parent2f17f23da38cf59cdf149533ddead3cb4739d774 (diff)
openvpn: explicitly disable engine parameter for openssl variant
Engine support is deprecated in OpenSSL 3.0 and for OpenSSL 3.0 the default is to disable engine support as engine support is deprecated. For ath79 architecture build with autodetection engine support fails, so explicitly set off for now. Signed-off-by: Ivan Pavlov <AuthorReflex@gmail.com>
-rw-r--r--net/openvpn/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/openvpn/Makefile b/net/openvpn/Makefile
index 2405aa9c0..86c7e88f5 100644
--- a/net/openvpn/Makefile
+++ b/net/openvpn/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openvpn
PKG_VERSION:=2.5.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=\
https://build.openvpn.net/downloads/releases/ \
@@ -87,7 +87,7 @@ define Build/Configure
$(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_DEF_AUTH),--enable,--disable)-def-auth \
$(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_PF),--enable,--disable)-pf \
$(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_PORT_SHARE),--enable,--disable)-port-share \
- $(if $(CONFIG_OPENVPN_OPENSSL),--with-crypto-library=openssl) \
+ $(if $(CONFIG_OPENVPN_OPENSSL),--with-crypto-library=openssl --with-openssl-engine=no) \
$(if $(CONFIG_OPENVPN_MBEDTLS),--with-crypto-library=mbedtls) \
$(if $(CONFIG_OPENVPN_WOLFSSL),--with-crypto-library=wolfssl) \
)