aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2019-02-02 11:04:37 +0200
committerGitHub <noreply@github.com>2019-02-02 11:04:37 +0200
commit61f9cf2fae349bc88942f3809591c7f6917806d4 (patch)
treeafb502da7a2f02ac9e9c62c9be70b1fcfb18f56a
parent4e3b866ed87c7dde8d9dd0d366e631efffbb59de (diff)
parentab2e94b294aab7422b9b1580f5c0a71ef5719a28 (diff)
Merge pull request #8104 from jefferyto/htpdate-init
htpdate: Update init script
-rw-r--r--net/htpdate/Makefile2
-rw-r--r--net/htpdate/files/htpdate.init14
2 files changed, 10 insertions, 6 deletions
diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
index 2650597e8..adf331a09 100644
--- a/net/htpdate/Makefile
+++ b/net/htpdate/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=htpdate
PKG_VERSION:=1.1.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www.vervest.org/htp/archive/c/
diff --git a/net/htpdate/files/htpdate.init b/net/htpdate/files/htpdate.init
index 88176c84c..2edd44d2f 100644
--- a/net/htpdate/files/htpdate.init
+++ b/net/htpdate/files/htpdate.init
@@ -9,7 +9,7 @@ PROG=/usr/sbin/htpdate
validate_htpdate_section() {
- uci_validate_section htpdate htpdate "${1}" \
+ uci_load_validate htpdate htpdate "$1" "$2" \
'server:list(host)' \
'proxy_host:host' \
'proxy_port:port:8080' \
@@ -20,10 +20,10 @@ validate_htpdate_section() {
}
-start_service() {
- local server proxy debug sanity_check option enabled
+start_htpdate_instance() {
+ local peer
- validate_htpdate_section htpdate || {
+ [ "$2" = 0 ] || {
echo "validation failed"
return 1
}
@@ -34,7 +34,7 @@ start_service() {
procd_open_instance
procd_set_param command "$PROG" -f
- [ -n "$proxy" ] && procd_append_param command -P $proxy:$proxy_port
+ [ -n "$proxy_host" ] && procd_append_param command -P $proxy_host:$proxy_port
[ "$debug" = "1" ] && procd_append_param command -d
[ "$sanity_check" = "0" ] && procd_append_param command -t
[ -n "$option" ] && procd_append_param command $option
@@ -48,6 +48,10 @@ start_service() {
procd_close_instance
}
+start_service() {
+ validate_htpdate_section htpdate start_htpdate_instance
+}
+
service_triggers() {
procd_add_reload_trigger "htpdate"
procd_add_validation validate_htpdate_section