aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-05-25 12:01:17 +0800
committerJeffery To <jeffery.to@gmail.com>2023-05-25 13:42:00 +0800
commit60bf01cb606344619e002901646171da1e69c0f9 (patch)
tree018b2d3d59a7eb426d4eddf86d6c77c2d2c81cfb
parent6b8340d3cad7a6bd36aa21c93de82c47bf871c33 (diff)
python3: Fix unnecessary linking with libbsd
configure will try to link with libbsd for the flock function, even when flock is available without it. Fixes: https://github.com/openwrt/packages/issues/21161 Fixes: 2445fe9fb25e ("python3: Update to 3.11.3, refresh/redo patches") Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python3/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 0a3e4cbc5..020d88a6e 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -153,6 +153,11 @@ CONFIGURE_VARS += \
ac_cv_file__dev_ptc=no \
ac_cv_file__dev_ptmx=yes
+# Do not link with libbsd for flock
+# https://github.com/openwrt/packages/issues/21161
+CONFIGURE_VARS += \
+ ac_cv_lib_bsd_flock=no
+
# Disable stdlib modules
# Check for a better way in the future: https://github.com/python/cpython/issues/98558
CONFIGURE_VARS += \