aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-09-13 23:17:55 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-09-13 23:19:39 +0100
commit5f9a1a142227cc78b961ac39a19772fb9a2d65d0 (patch)
tree37965e21e78ffbf43a67beaa8becc3ecf722c385
parentdecc5f51f46c75934d3a74abad210b9109be6eb1 (diff)
gnunet: update to version 0.13.3
Apart from adapting to upstream changes also switch to use FILE_MODES instead of chown/chmod in init-script. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--net/gnunet/Makefile32
-rwxr-xr-xnet/gnunet/files/gnunet.init24
-rw-r--r--net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch4
3 files changed, 21 insertions, 39 deletions
diff --git a/net/gnunet/Makefile b/net/gnunet/Makefile
index 65410b532..f2e19b6c6 100644
--- a/net/gnunet/Makefile
+++ b/net/gnunet/Makefile
@@ -2,11 +2,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gnunet
-PKG_VERSION:=0.13.1
+PKG_VERSION:=0.13.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/gnunet
-PKG_HASH:=03d76a852e7fd2fc87b7145cb6abd900f73e4ea6097f3caac9e7d9fe8b625696
+PKG_HASH:=318e06c4134d1a8ce3b4385d82b11316eaaeb9a4dbc5d4b646453dfc53199296
PKG_LICENSE:=AGPL-3.0
PKG_LICENSE_FILES:=COPYING
@@ -58,6 +58,8 @@ $(call Package/gnunet/Default)
+libunistring +librt +zlib $(ICONV_DEPENDS) $(INTL_DEPENDS)
USERID:=gnunet=958:gnunet=958
MENU:=1
+ FILE_MODES:=/usr/lib/gnunet/libexec/gnunet-helper-nat-server:root:958:4750 \
+ /usr/lib/gnunet/libexec/gnunet-helper-nat-client:root:958:4750
endef
define Package/gnunet/description
@@ -84,6 +86,7 @@ define BuildComponent
$(if $(3),DEFAULT:=y if PACKAGE_gnunet)
$(if $(USERID_$(1)),USERID:=$(USERID_$(1)))
$(if $(CONFLICTS_$(1)),CONFLICTS:=$(CONFLICTS_$(1)))
+ $(if $(FILE_MODES_$(1)),FILE_MODES:=$(FILE_MODES_$(1)))
endef
define Package/gnunet-$(1)/install
@@ -135,20 +138,20 @@ define Package/gnunet/install
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/gnunet/libexec
$(INSTALL_DIR) $(1)/usr/share/gnunet/config.d $(1)/usr/share/gnunet/hellos
- ( for bin in arm ats ats-new cadet core config ecc identity nat nat-auto nat-server nse \
+ ( for bin in arm ats cadet core config ecc identity nat nat-auto nat-server nse \
peerinfo peerstore revocation scalarproduct scrypt statistics transport uri; do \
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gnunet-$$$$bin $(1)/usr/bin/ ; \
done )
- ( for lib in arm ats atsapplication atstransport block blockgroup cadet \
- core datacache dht dns dnsparser fragmentation friends hello \
+ ( for lib in arm ats block blockgroup cadet \
+ core datacache dht dns fragmentation friends hello \
identity natauto natnew nse nt peerinfo peerstore regexblock regex revocation \
- scalarproduct set statistics transport transportaddress transportapplication \
+ scalarproduct set seti setu statistics transport transportapplication \
transportcommunicator transportcore transportmonitor util; do \
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnunet$$$$lib.so* $(1)/usr/lib/ ; \
done )
- ( for plug in ats_proportional ats2_simple block_dht block_regex block_revocation transport_unix; do \
+ ( for plug in ats_proportional block_dht block_regex block_revocation transport_unix; do \
$(CP) $(PKG_INSTALL_DIR)/usr/lib/gnunet/libgnunet_plugin_$$$$plug*.so $(1)/usr/lib/gnunet ; \
done )
@@ -158,14 +161,14 @@ define Package/gnunet/install
service-nse service-peerinfo service-peerstore service-regex \
service-revocation service-scalarproduct-alice \
service-scalarproduct-bob service-scalarproduct-ecc-alice \
- service-scalarproduct-ecc-bob service-set service-statistics \
+ service-scalarproduct-ecc-bob service-set service-seti service-setu service-statistics \
service-transport timeout; do \
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/gnunet/libexec/gnunet-$$$$lex $(1)/usr/lib/gnunet/libexec ; \
done )
( for conf in arm ats cadet communicator-unix core datacache dht identity \
- identity-provider nat nat-auto nse peerinfo peerstore regex revocation \
- scalarproduct set statistics topology transport util; do \
+ nat nat-auto nse peerinfo peerstore regex revocation \
+ scalarproduct set seti setu statistics topology transport util; do \
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/gnunet/config.d/$$$$conf.conf $(1)/usr/share/gnunet/config.d ; \
done )
@@ -219,6 +222,7 @@ CONF_hostlist:=hostlist
DEPENDS_transport-bluetooth:=+bluez-libs
PLUGIN_transport-bluetooth:=transport_bluetooth
LIBEXEC_transport-bluetooth:=helper-transport-bluetooth
+FILE_MODES_transport-bluetooth:=/usr/lib/gnunet/libexec/gnunet-helper-transport-bluetooth:root:958:4750
DEPENDS_transport-http_client:=+gnunet-curl +ca-certificates
PLUGIN_transport-http_client:=transport_http_client transport_https_client
@@ -232,6 +236,7 @@ PLUGIN_transport-udp:=transport_udp
PLUGIN_transport-wlan:=transport_wlan
LIBEXEC_transport-wlan:=helper-transport-wlan
+FILE_MODES_transport-wlan:=/usr/lib/gnunet/libexec/gnunet-helper-transport-wlan:root:958:4750
# BIN_dv:=dv
LIB_dv:=dv
@@ -253,6 +258,7 @@ LIB_gns:=gns gnsrecord namecache namestore
PLUGIN_gns:=block_dns block_gns gnsrecord_conversation gnsrecord_dns gnsrecord_gns
LIBEXEC_gns:=dns2gns helper-dns service-dns service-gns service-namecache service-namestore service-resolver service-zonemaster
CONF_gns:=dns gns namecache namestore resolver zonemaster
+FILE_MODES_gns:=/usr/lib/gnunet/libexec/gnunet-helper-dns:root:452:4750 /usr/lib/gnunet/libexec/gnunet-service-dns:958:452:2750
DEPENDS_namestore-fcfsd:=+gnunet-gns +libmicrohttpd-ssl
LIBEXEC_namestore-fcfsd:=namestore-fcfsd
@@ -272,11 +278,11 @@ BIN_reclaim:=reclaim
LIB_reclaim:=consensus abe reclaim reclaimattribute secretsharing
LIBEXEC_reclaim:=service-consensus service-reclaim service-secretsharing
CONF_reclaim:=consensus reclaim secretsharing
-PLUGIN_reclaim:=block_consensus gnsrecord_reclaim reclaim_attestation_jwt reclaim_attribute_basic
+PLUGIN_reclaim:=block_consensus gnsrecord_reclaim reclaim_credential_jwt reclaim_attribute_basic
DEPENDS_rest:=+gnunet-gns +gnunet-reclaim +libmicrohttpd-ssl +jansson
LIB_rest:=rest json
-PLUGIN_rest:=rest_copying rest_gns rest_identity rest_namestore rest_peerinfo rest_openid_connect rest_reclaim
+PLUGIN_rest:=rest_config rest_copying rest_gns rest_identity rest_namestore rest_peerinfo rest_openid_connect rest_reclaim
LIBEXEC_rest:=rest-server
CONF_rest:=rest
@@ -343,11 +349,11 @@ BIN_utils:=gns-proxy-setup-ca transport-certificate-creation
DEPENDS_vpn:=+kmod-tun +iptables +firewall
BIN_vpn:=vpn
+FILE_MODES_vpn:=/usr/lib/gnunet/libexec/gnunet-helper-exit:root:958:4750 /usr/lib/gnunet/libexec/gnunet-helper-vpn:root:958:4750
LIB_vpn:=dnsstub tun vpn
LIBEXEC_vpn:=daemon-exit daemon-pt helper-exit helper-vpn service-vpn
CONF_vpn:=exit pt vpn
-
define Package/gnunet-gns/prerm
#!/bin/sh
diff --git a/net/gnunet/files/gnunet.init b/net/gnunet/files/gnunet.init
index 722620c69..90971d8eb 100755
--- a/net/gnunet/files/gnunet.init
+++ b/net/gnunet/files/gnunet.init
@@ -9,31 +9,8 @@ PROG=/usr/lib/gnunet/libexec/gnunet-service-arm
GNUNET_HOME=/var/run/gnunet
# LOGFILE=$GNUNET_HOME/gnunet.log
CONFIGFILE=$GNUNET_HOME/gnunet.conf
-SUID_ROOT_HELPERS="exit nat-server nat-client transport-bluetooth transport-wlan vpn"
EXTRA_COMMANDS="restart_transport"
-chmodown_execbin() {
- execname=/usr/lib/gnunet/libexec/gnunet-$1
- if [ -x $execname ]; then
- if [ "$3" ]; then
- chown $3 $execname 2>/dev/null && chmod $2 $execname
- else
- chmod $2 $execname
- fi
- fi
-}
-
-fix_libexec_permissions() {
- [ -e /usr/share/gnunet/.permfix ] && return
- for helper in $SUID_ROOT_HELPERS; do
- chmodown_execbin helper-$helper u+s
- done
- chmodown_execbin helper-dns 4750 root:gnunetdns
- chmodown_execbin service-dns 2750 gnunet:gnunetdns
-
- touch /usr/share/gnunet/.permfix
-}
-
prepare_config() {
local had_exit_service=0;
@@ -109,7 +86,6 @@ restart_transport() {
}
start_service() {
- fix_libexec_permissions
prepare_config
procd_open_instance
diff --git a/net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch b/net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch
index cfc79bd0f..ee416ea72 100644
--- a/net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch
+++ b/net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -811,10 +811,12 @@ AC_ARG_WITH(libpulse,
+@@ -813,10 +813,12 @@ AC_ARG_WITH(libpulse,
LDFLAGS="-L$with_libpulse/lib $LDFLAGS"
CPPFLAGS="-I$with_libpulse/include $CPPFLAGS"
AC_CHECK_HEADERS(pulse/simple.h,
@@ -17,7 +17,7 @@
])
],
[AC_MSG_RESULT([--with-libpulse not specified])
-@@ -854,10 +856,12 @@ AC_ARG_WITH(libopus,
+@@ -856,10 +858,12 @@ AC_ARG_WITH(libopus,
LDFLAGS="-L$with_libopus/lib $LDFLAGS"
CPPFLAGS="-I$with_libopus/include $CPPFLAGS"
AC_CHECK_HEADERS(opus/opus.h,