aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-07-17 13:50:00 +0800
committerRosen Penev <rosenp@gmail.com>2023-07-17 11:44:53 -0700
commit5e66a69433e59c5f1089167917364f91b45b91be (patch)
tree8d9dd4b7401fcb1d0ceb67402ee65d0bf85598f9
parentf60a0b2b46078e9832582e5022399c2a9ca4b7a4 (diff)
python-pip: Update to 23.2
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python-pip/Makefile4
-rw-r--r--lang/python/python-pip/test.sh5
2 files changed, 7 insertions, 2 deletions
diff --git a/lang/python/python-pip/Makefile b/lang/python/python-pip/Makefile
index 97a5326bc..7dee1f965 100644
--- a/lang/python/python-pip/Makefile
+++ b/lang/python/python-pip/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-pip
-PKG_VERSION:=23.1.2
+PKG_VERSION:=23.2
PKG_RELEASE:=1
PYPI_NAME:=pip
-PKG_HASH:=0e7c86f486935893c708287b30bd050a36ac827ec7fe5e43fe7cb198dd835fba
+PKG_HASH:=a160a170f3331d9ca1a0247eb1cd79c758879f1f81158f9cd05bbb5df80bea5c
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE.txt
diff --git a/lang/python/python-pip/test.sh b/lang/python/python-pip/test.sh
new file mode 100644
index 000000000..10355b3e3
--- /dev/null
+++ b/lang/python/python-pip/test.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+[ "$1" = python3-pip ] || exit 0
+
+pip --version | grep -F "pip $PKG_VERSION "