aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-06-24 15:19:44 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-06-24 16:02:25 +0200
commit5d31eaccc6969506737dce20cc4496dbce17b2ee (patch)
tree7b5251c50411ed5ed812f4901f943dbb6090cd55
parent01f86b1f300f715458ae81daf4d2fc6797bdd647 (diff)
add xr_usb_serial_common driver for USB to RS-485/RS-422
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--libs/xr_usb_serial_common/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/libs/xr_usb_serial_common/Makefile b/libs/xr_usb_serial_common/Makefile
new file mode 100644
index 000000000..a2091dfa9
--- /dev/null
+++ b/libs/xr_usb_serial_common/Makefile
@@ -0,0 +1,41 @@
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=usb-serial-xr_usb_serial_common
+PKG_VERSION:=1a
+PKG_RELEASE=1
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=
+
+PKG_SOURCE_URL:=https://github.com/kasbert/epsolar-tracer
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=8c21f4afdfd6acd77b6adad59a4dabe5cbf2b947
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
+
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/usb-serial-xr_usb_serial_common
+ SECTION:=kernel
+ CATEGORY:=Kernel modules
+ SUBMENU:=USB Support
+ TITLE:=Support for Exar USB to RS-485/RS-422
+ URL:=https://www.exar.com/content/document.ashx?id=21651
+ FILES:=$(PKG_BUILD_DIR)/xr_usb_serial_common-1a/xr_usb_serial_common.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoProbe,xr_usb_serial_common)
+ DEPENDS+=kmod-usb-serial
+endef
+
+define Build/Compile
+ +$(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ SUBDIRS="$(PKG_BUILD_DIR)/xr_usb_serial_common-1a" \
+ modules
+endef
+
+$(eval $(call KernelPackage,usb-serial-xr_usb_serial_common))