aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-12 13:00:52 -0700
committerRosen Penev <rosenp@gmail.com>2020-08-13 21:44:42 -0700
commit5c60cc78dcd1df2df961ac275d4e1f5ce6da555e (patch)
tree0974133de2d34efda99428efe3635edc9cf917fe
parentd8d06cfca262d97c7d3a3481c6a0f2cd3803c250 (diff)
keyutils: fix deprecated function usage
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/keyutils/Makefile2
-rw-r--r--libs/keyutils/patches/020-rindex.patch17
2 files changed, 18 insertions, 1 deletions
diff --git a/libs/keyutils/Makefile b/libs/keyutils/Makefile
index 7c8390e0e..f7186e989 100644
--- a/libs/keyutils/Makefile
+++ b/libs/keyutils/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=keyutils
PKG_VERSION:=1.6.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://people.redhat.com/dhowells/keyutils/
diff --git a/libs/keyutils/patches/020-rindex.patch b/libs/keyutils/patches/020-rindex.patch
new file mode 100644
index 000000000..11cf6c09c
--- /dev/null
+++ b/libs/keyutils/patches/020-rindex.patch
@@ -0,0 +1,17 @@
+--- a/key.dns_resolver.c
++++ b/key.dns_resolver.c
+@@ -529,12 +529,12 @@ int main(int argc, char *argv[])
+ keyend = buf + ktlen + 1;
+
+ /* the actual key description follows the last semicolon */
+- keyend = rindex(keyend, ';');
++ keyend = strrchr(keyend, ';');
+ if (!keyend)
+ error("Invalid key description: %s", buf);
+ keyend++;
+
+- name = index(keyend, ':');
++ name = strchr(keyend, ':');
+ if (!name)
+ dns_query_a_or_aaaa(keyend, callout_info);
+