aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorejurgensen <espenjurgensen@gmail.com>2015-06-25 22:40:46 +0200
committerejurgensen <espenjurgensen@gmail.com>2015-06-25 22:40:46 +0200
commit5c0d03417141b222e69b2d513226ecf00e876951 (patch)
treef55ad6315117db13fb14655005aeb3aa313edec4
parent1c66cd37e85806245791d80ac813199cd66a4c2d (diff)
forked-daapd: update to 23.2
Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
-rw-r--r--sound/forked-daapd/Makefile25
-rw-r--r--sound/forked-daapd/files/forked-daapd.conf24
2 files changed, 25 insertions, 24 deletions
diff --git a/sound/forked-daapd/Makefile b/sound/forked-daapd/Makefile
index 8599c3831..51f459f0f 100644
--- a/sound/forked-daapd/Makefile
+++ b/sound/forked-daapd/Makefile
@@ -8,9 +8,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=forked-daapd
-PKG_VERSION:=22.3
-PKG_RELEASE:=20150222
-PKG_REV:=81b0d330691ce22879514af04c7d831bca8a6e19
+PKG_VERSION:=23.2
+PKG_RELEASE:=20150622
+PKG_REV:=227017ef5ba8df921b2f1db681a46494ec296b8b
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -35,29 +35,36 @@ CATEGORY:=Sound
TITLE:=iTunes (DAAP) server for Apple Remote and AirPlay
URL:=https://github.com/ejurgensen/forked-daapd
DEPENDS:=+libgpg-error +libgcrypt +libgdbm +zlib +libexpat +libunistring \
- +libevent2 +libdaemon +libantlr3c +confuse +glib2 +alsa-lib +libffmpeg-full \
+ +libevent2 +libdaemon +libantlr3c +confuse +alsa-lib +libffmpeg-full \
+mxml +libavahi-client +sqlite3-cli +libplist +libcurl
endef
+define Package/forked-daapd/description
+ forked-daapd is a Linux/FreeBSD DAAP (iTunes), MPD (Music Player Daemon) and
+ RSP (Roku) media server. It has support for AirPlay devices/speakers, Apple
+ Remote (and compatibles), MPD clients, internet radio and LastFM. It does not
+ support AirPlay video.
+endef
+
define Package/forked-daapd/conffiles
/etc/forked-daapd.conf
endef
CONFIGURE_ARGS += \
--enable-itunes \
- --enable-lastfm
+ --enable-lastfm \
+ --enable-mpd
TARGET_CFLAGS += $(FPIC)
TARGET_LDFLAGS += -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
define Package/forked-daapd/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/forked-daapd $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc
- $(INSTALL_DATA) ./files/forked-daapd.conf $(1)/etc/
- $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_CONF) ./files/forked-daapd.conf $(1)/etc/forked-daapd.conf
$(INSTALL_DIR) $(1)/usr/lib/forked-daapd
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/forked-daapd/* $(1)/usr/lib/forked-daapd/
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/forked-daapd $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/forked-daapd.init $(1)/etc/init.d/forked-daapd
endef
diff --git a/sound/forked-daapd/files/forked-daapd.conf b/sound/forked-daapd/files/forked-daapd.conf
index 63c0ac3db..0f756e0f8 100644
--- a/sound/forked-daapd/files/forked-daapd.conf
+++ b/sound/forked-daapd/files/forked-daapd.conf
@@ -14,7 +14,7 @@ general {
uid = "daapd"
# Database location
-# db_path = "/var/cache/forked-daapd/songs3.db"
+ db_path = "/var/cache/forked-daapd/songs3.db"
# Log file and level
# Available levels: fatal, log, warning, info, debug, spam
@@ -28,7 +28,7 @@ general {
ipv6 = no
# Location of cache database
-# cache_path = "/var/cache/forked-daapd/cache.db"
+ cache_path = "/var/cache/forked-daapd/cache.db"
# DAAP requests that take longer than this threshold (in msec) get their
# replies cached for next time. Set to 0 to disable caching.
@@ -78,6 +78,12 @@ library {
# (changing this setting only takes effect after rescan, see the README)
compilation_artist = "Various artists"
+ # Internet streams in your playlists will by default be shown in the
+ # "Radio" library, like iTunes does. However, some clients (like
+ # TunesRemote+) won't show the "Radio" library. If you would also like
+ # to have them shown like normal playlists, you can enable this option.
+# radio_playlists = false
+
# There are 5 default playlists: "Library", "Music", "Movies", "TV Shows"
# and "Podcasts". Here you can change the names of these playlists.
# name_library = "Library"
@@ -86,6 +92,7 @@ library {
# name_tvshows = "TV Shows"
# name_podcasts = "Podcasts"
# name_audiobooks = "Audiobooks"
+# name_radio = "Radio"
# Artwork file names (without file type extension)
# forked-daapd will look for jpg and png files with these base names
@@ -152,19 +159,6 @@ audio {
# password = "s1kr3t"
#}
-# Spotify settings (only have effect if Spotify enabled - see README/INSTALL)
-spotify {
- # Directory where user settings should be stored (credentials)
-# settings_dir = "/var/cache/forked-daapd/libspotify"
-
- # Cache directory
-# cache_dir = "/tmp"
-
- # Set preferred bitrate for music streaming
- # 0: No preference (default), 1: 96kbps, 2: 160kbps, 3: 320kbps
-# bitrate = 0
-}
-
# SQLite configuration (allows to modify the operation of the SQLite databases)
# Make sure to read the SQLite documentation for the corresponding PRAGMA statements as
# changing them from the defaults may increase the possibility of database corruptions!