aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-18 15:04:55 -0800
committerGitHub <noreply@github.com>2020-12-18 15:04:55 -0800
commit5b2a507b6bb0ab4287993f6c1abd32491294cd47 (patch)
tree5625dcbab1bcf2551a0f9df553915e498c493a52
parent8e9d6f9459c47ab4a5e7debbfa668ad6df87d0a8 (diff)
parent5f5248be7d544aa7859e5dbee230fe9fd8e483dd (diff)
Merge pull request #14223 from tofurky/fwknop_gpgme_deps
fwknop: gpgme: fix build of fwknop with gpg enabled
-rw-r--r--libs/gpgme/Makefile11
-rw-r--r--net/fwknop/Config.in3
-rw-r--r--net/fwknop/Makefile10
3 files changed, 17 insertions, 7 deletions
diff --git a/libs/gpgme/Makefile b/libs/gpgme/Makefile
index 1123f579a..da766a341 100644
--- a/libs/gpgme/Makefile
+++ b/libs/gpgme/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gpgme
PKG_VERSION:=1.15.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://gnupg.org/ftp/gcrypt/$(PKG_NAME)
@@ -83,6 +83,15 @@ define Build/InstallDev
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/cmake/Gpgmepp/*.cmake \
$(1)/usr/lib/cmake/Gpgmepp
+
+ $(INSTALL_DIR) $(2)/bin $(1)/usr/bin
+ $(INSTALL_BIN) \
+ $(PKG_INSTALL_DIR)/usr/bin/gpgme-config \
+ $(2)/bin/
+ $(SED) \
+ 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+ $(2)/bin/gpgme-config
+ $(LN) -sf $(STAGING_DIR)/host/bin/gpgme-config $(1)/usr/bin/gpgme-config
endef
define Package/libgpgme/install
diff --git a/net/fwknop/Config.in b/net/fwknop/Config.in
index 940e811ba..8de7e4715 100644
--- a/net/fwknop/Config.in
+++ b/net/fwknop/Config.in
@@ -1,6 +1,6 @@
#fwknop config
menu "Configuration"
- depends on PACKAGE_fwknopd
+ depends on PACKAGE_fwknopd || PACKAGE_fwknop
config FWKNOPD_GPG
bool "Enable GPG support"
@@ -12,5 +12,4 @@ config FWKNOPD_NFQ_CAPTURE
select PACKAGE_iptables-mod-nfqueue
default n
-
endmenu
diff --git a/net/fwknop/Makefile b/net/fwknop/Makefile
index 5a79dd4c6..cfcf8a27f 100644
--- a/net/fwknop/Makefile
+++ b/net/fwknop/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=fwknop
PKG_VERSION:=2.6.10
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.cipherdyne.org/fwknop/download
@@ -47,8 +47,9 @@ define Package/fwknopd
CATEGORY:=Network
SUBMENU:=Firewall
TITLE+= Daemon
- DEPENDS:=+iptables +libfko +!FWKNOPD_NFQ_CAPTURE:libpcap +FWKNOPD_NFQ_CAPTURE:iptables-mod-nfqueue +FWKNOP_GPG:gnupg \
- +FWKNOPD_NFQ_CAPTURE:libnetfilter-queue +FWKNOPD_NFQ_CAPTURE:libnfnetlink
+ DEPENDS:=+iptables +libfko +!FWKNOPD_NFQ_CAPTURE:libpcap +FWKNOPD_NFQ_CAPTURE:iptables-mod-nfqueue \
+ +FWKNOPD_NFQ_CAPTURE:libnetfilter-queue +FWKNOPD_NFQ_CAPTURE:libnfnetlink \
+ +FWKNOP_GPG:gnupg +FWKNOP_GPG:libgpgme
endef
define Package/fwknopd/description
@@ -72,7 +73,7 @@ define Package/fwknop
CATEGORY:=Network
SUBMENU:=Firewall
TITLE+= Client
- DEPENDS:=+libfko
+ DEPENDS:=+libfko +FWKNOPD_GPG:gnupg +FWKNOPD_GPG:libgpgme
endef
define Package/fwknop/description
@@ -86,6 +87,7 @@ define Package/libfko
CATEGORY:=Libraries
SUBMENU:=Firewall
TITLE+= Library
+ DEPENDS:=+FWKNOPD_GPG:gnupg +FWKNOPD_GPG:libgpgme
endef
define Package/libfko/description