aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Denia <naoir@gmx.net>2014-07-07 22:46:33 +0200
committerMarcel Denia <naoir@gmx.net>2014-07-08 00:39:29 +0200
commit599d348effa93505a1a77b22c442829d36a6f3a9 (patch)
tree2a169cb454d0a0b88aa73cb29ec794090943f73c
parent7534bea1979017d410b537ab06a3c1581449840d (diff)
lang/perl: Don't build target miniperl
The target miniperl binary wasn't used at all. It is intended for bootstrapping during build when not cross-compiling. Signed-off-by: Marcel Denia <naoir@gmx.net>
-rw-r--r--lang/perl/Makefile23
1 files changed, 5 insertions, 18 deletions
diff --git a/lang/perl/Makefile b/lang/perl/Makefile
index 935a1abdb..6c10c519f 100644
--- a/lang/perl/Makefile
+++ b/lang/perl/Makefile
@@ -129,38 +129,25 @@ endef
define Build/perl/Compile
@echo
- @echo "===> Stage 4: Build target miniperl binary"
+ @echo "===> Stage 4: Build target perl binary"
@echo
install -m 0644 $(PKG_BUILD_DIR)/config.h $(PKG_BUILD_DIR)/xconfig.h
- +$(MAKE) $(MAKE_J) -C $(PKG_BUILD_DIR) miniperl
- # Due to the new cross compiling support, make miniperl will never
- # actually link a target miniperl binary, but will always symlink
- # the one from host-perl. To compensate that, we add a custom rule
- # to the Makefile that corresponds to the one that would have
- # been generated if we weren't cross compiling
- echo -e 'miniperl.target:\n\t$$$$(CC) $$$$(CLDFLAGS) -o miniperl.target $$$$(mini_obj) $$$$(libs)' >> $(PKG_BUILD_DIR)/Makefile
- +$(MAKE) $(MAKE_J) -C $(PKG_BUILD_DIR) miniperl.target
- mkdir -p $(PKG_BUILD_DIR)/target-bin
- install -m 0755 $(PKG_BUILD_DIR)/miniperl.target $(PKG_BUILD_DIR)/target-bin/miniperl
-
- @echo
- @echo "===> Stage 5: Build target perl binary"
- @echo
+$(MAKE) $(MAKE_J) -C $(PKG_BUILD_DIR) perl
+ mkdir -p $(PKG_BUILD_DIR)/target-bin
install -m 0755 $(PKG_BUILD_DIR)/perl $(PKG_BUILD_DIR)/target-bin/
@echo
- @echo "===> Stage 6: Build target extensions and utils"
+ @echo "===> Stage 5: Build target extensions and utils"
@echo
+$(MAKE) $(MAKE_J) -C $(PKG_BUILD_DIR)
@echo
- @echo "===> Stage 7: Install Perl into staging dir"
+ @echo "===> Stage 6: Install Perl into staging dir"
@echo
(cd $(PKG_BUILD_DIR) && ./miniperl installperl --destdir=$(STAGING_DIR))
@echo
- @echo "===> Stage 8: Install Perl into a temporary root"
+ @echo "===> Stage 7: Install Perl into a temporary root"
@echo
mkdir -p $(PKG_INSTALL_DIR)
(cd $(PKG_BUILD_DIR) && ./miniperl installperl --destdir=$(PKG_INSTALL_DIR))