aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorejurgensen <espenjurgensen@gmail.com>2014-10-16 23:27:04 +0200
committerejurgensen <espenjurgensen@gmail.com>2014-10-18 21:52:25 +0200
commit560598ca2299247aa142a4c11b655e0717f59796 (patch)
tree1dd8cf0b43f5802f8b68d1f89d912f96dd6ce162
parent8365b52b2087a22c85cf7afc06f27cf6132904b7 (diff)
libunistring: add version 0.9.4
Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
1 files changed, 59 insertions, 0 deletions
diff --git a/libs/libunistring/Makefile b/libs/libunistring/Makefile
new file mode 100644
index 000000000..6d69b57d8
--- /dev/null
+++ b/libs/libunistring/Makefile
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libunistring
+PKG_VERSION:=0.9.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=c24a6a3838d9ad4a41a62549312c4226
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/libunistring
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+PKG_MAINTAINER:=Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
+PKG_LICENSE:=GPL-3.0
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libunistring
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=libunistring
+ URL:=http://www.gnu.org/software/libunistring/
+endef
+
+define Package/libunistring/description
+ This library provides functions for manipulating Unicode strings and for manipulating C strings according to the Unicode standard.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --without-libiconv-prefix \
+ --without-libpth-prefix
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/include/unistring
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/unistring/*.h $(1)/usr/include/unistring/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libunistring.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/libunistring/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libunistring.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libunistring))