aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leonard <antonlacon@gmail.com>2020-08-14 12:22:43 -0700
committerIan Leonard <antonlacon@gmail.com>2020-10-02 22:01:58 -0700
commit54b6de172db90f328a047c5b4e45be81e5a97769 (patch)
tree03f11f443a1c7d1d481b79b1f406c8130588a69d
parent100f43e60e30cdedc417e14abdb8b0f03ebd91d3 (diff)
rsync: add config option for zstd support
Signed-off-by: Ian Leonard <antonlacon@gmail.com>
-rw-r--r--net/rsync/Config.in5
-rw-r--r--net/rsync/Makefile6
2 files changed, 8 insertions, 3 deletions
diff --git a/net/rsync/Config.in b/net/rsync/Config.in
index 5c297f400..f5e3b67b1 100644
--- a/net/rsync/Config.in
+++ b/net/rsync/Config.in
@@ -12,4 +12,9 @@ if PACKAGE_rsync
default y if USE_FS_ACL_ATTR
default n
+ config RSYNC_zstd
+ bool
+ prompt "Enable zstd stream compression"
+ default n
+
endif
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 6452def0e..a207455c6 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rsync
PKG_VERSION:=3.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.samba.org/pub/rsync/src
@@ -30,7 +30,7 @@ define Package/rsync
CATEGORY:=Network
SUBMENU:=File Transfer
TITLE:=Fast remote file copy program (like rcp)
- DEPENDS:=+libpopt +zlib +RSYNC_xattr:libattr +RSYNC_acl:libacl
+ DEPENDS:=+libpopt +zlib +RSYNC_xattr:libattr +RSYNC_acl:libacl +RSYNC_zstd:libzstd
URL:=https://rsync.samba.org/
MENU:=1
endef
@@ -54,7 +54,7 @@ CONFIGURE_ARGS += \
--disable-openssl \
--disable-simd \
--disable-xxhash \
- --disable-zstd \
+ --$(if $(CONFIG_RSYNC_zstd),en,dis)able-zstd \
--$(if $(CONFIG_RSYNC_xattr),en,dis)able-xattr-support \
--$(if $(CONFIG_RSYNC_acl),en,dis)able-acl-support \
$(if $(CONFIG_IPV6),,--disable-ipv6)