aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2017-07-08 08:30:14 -0700
committerEtienne Champetier <champetier.etienne@gmail.com>2017-07-08 08:30:14 -0700
commit547f30b4684cbc3b5e414f8ac0302452ddc5be3a (patch)
tree4a44c684d6235caf522f8010ac55b3a9b8e5883d
parent1a087b6ab9c71d28397ee577628b364fcdf52301 (diff)
zabbix: partially fix zabbix-extra-mac80211
In kernel commit f1160434c7658af3f7b0926b88df49a66cb3c3e0 many stats that we read with zabbix-extra-mac80211 have been renamed One commit after (c206ca670974cefec7ac3732db5c8156e8081a8d) those renamed stats have been hidden behind MAC80211_DEBUG_COUNTERS compile flag For now you have to edit mac80211 Makefile / do a custom build to access most of these stats Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
-rw-r--r--admin/zabbix/Makefile2
-rw-r--r--admin/zabbix/files/mac8021120
2 files changed, 12 insertions, 10 deletions
diff --git a/admin/zabbix/Makefile b/admin/zabbix/Makefile
index dcc41b9e5..0eedff0f5 100644
--- a/admin/zabbix/Makefile
+++ b/admin/zabbix/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zabbix
PKG_VERSION:=3.2.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_HASH:=22cf19ef5a9478df2281bf518e8be38adc7dbc508bf63111e02388ca7aabeef4
diff --git a/admin/zabbix/files/mac80211 b/admin/zabbix/files/mac80211
index afa50aeba..a567f85ce 100644
--- a/admin/zabbix/files/mac80211
+++ b/admin/zabbix/files/mac80211
@@ -15,13 +15,15 @@ UserParameter=mac80211.ACKFailureCount[*],zabbix_helper_mac80211 $1 dot11ACKFail
UserParameter=mac80211.FCSErrorCount[*],zabbix_helper_mac80211 $1 dot11FCSErrorCount
UserParameter=mac80211.RTSFailureCount[*],zabbix_helper_mac80211 $1 dot11RTSFailureCount
UserParameter=mac80211.RTSSuccessCount[*],zabbix_helper_mac80211 $1 dot11RTSSuccessCount
-UserParameter=mac80211.FailedCount[*],zabbix_helper_mac80211 $1 failed_count
-UserParameter=mac80211.FrameDuplicateCount[*],zabbix_helper_mac80211 $1 frame_duplicate_count
-UserParameter=mac80211.MulticastReceivedFrameCount[*],zabbix_helper_mac80211 $1 multicast_received_frame_count
-UserParameter=mac80211.MulticastTransmittedFrameCount[*],zabbix_helper_mac80211 $1 multicast_transmitted_frame_count
-UserParameter=mac80211.MultipleRetryCount[*],zabbix_helper_mac80211 $1 multiple_retry_count
-UserParameter=mac80211.ReceivedFragmentCount[*],zabbix_helper_mac80211 $1 received_fragment_count
-UserParameter=mac80211.RetryCount[*],zabbix_helper_mac80211 $1 retry_count
-UserParameter=mac80211.TransmittedFragmentCount[*],zabbix_helper_mac80211 $1 transmitted_fragment_count
-UserParameter=mac80211.TransmittedFrameCount[*],zabbix_helper_mac80211 $1 transmitted_frame_count
+
+# hidden behind MAC80211_DEBUG_COUNTERS
+UserParameter=mac80211.FailedCount[*],zabbix_helper_mac80211 $1 dot11FailedCount
+UserParameter=mac80211.FrameDuplicateCount[*],zabbix_helper_mac80211 $1 dot11FrameDuplicateCount
+UserParameter=mac80211.MulticastReceivedFrameCount[*],zabbix_helper_mac80211 $1 dot11MulticastReceivedFrameCount
+UserParameter=mac80211.MulticastTransmittedFrameCount[*],zabbix_helper_mac80211 $1 dot11MulticastTransmittedFrameCount
+UserParameter=mac80211.MultipleRetryCount[*],zabbix_helper_mac80211 $1 dot11MultipleRetryCount
+UserParameter=mac80211.ReceivedFragmentCount[*],zabbix_helper_mac80211 $1 dot11ReceivedFragmentCount
+UserParameter=mac80211.RetryCount[*],zabbix_helper_mac80211 $1 dot11RetryCount
+UserParameter=mac80211.TransmittedFragmentCount[*],zabbix_helper_mac80211 $1 dot11TransmittedFragmentCount
+UserParameter=mac80211.TransmittedFrameCount[*],zabbix_helper_mac80211 $1 dot11TransmittedFrameCount