aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2022-04-11 21:33:57 +0200
committerDirk Brenken <dev@brenken.org>2022-04-11 21:33:57 +0200
commit51a5ec60690674d4525dd14bade280110743e61b (patch)
treea3d65bad47766ac36f3b044bbc3f788151e82f44
parent8579494bbbfaf5c47049e9365ccfb7b553621d15 (diff)
adblock: 4.1.3-8
* add new 'hblock' compilation source (XL, see https://hblock.molinero.dev for reference) * print runtime/date information in ISO-8601 standard format * minor cleanups Signed-off-by: Dirk Brenken <dev@brenken.org>
-rw-r--r--net/adblock/Makefile2
-rw-r--r--net/adblock/files/README.md1
-rwxr-xr-xnet/adblock/files/adblock.sh12
-rw-r--r--net/adblock/files/adblock.sources11
4 files changed, 17 insertions, 9 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index b64becd67..d2987d698 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
PKG_VERSION:=4.1.3
-PKG_RELEASE:=7
+PKG_RELEASE:=8
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/README.md b/net/adblock/files/README.md
index 00350449d..0336bab50 100644
--- a/net/adblock/files/README.md
+++ b/net/adblock/files/README.md
@@ -22,6 +22,7 @@ A lot of people already use adblocker plugins within their desktop browsers, but
| energized | | VAR | compilation | [Link](https://energized.pro) |
| firetv_tracking | | S | tracking | [Link](https://github.com/Perflyst/PiHoleBlocklist) |
| games_tracking | | S | tracking | [Link](https://www.gameindustry.eu) |
+| hblock | | XL | compilation | [Link](https://hblock.molinero.dev) |
| notracking | | XL | tracking | [Link](https://github.com/notracking/hosts-blocklists) |
| oisd_basic | | L | general | [Link](https://oisd.nl) |
| oisd_full | | XXL | general | [Link](https://oisd.nl) |
diff --git a/net/adblock/files/adblock.sh b/net/adblock/files/adblock.sh
index 24141f9c3..0c6efc648 100755
--- a/net/adblock/files/adblock.sh
+++ b/net/adblock/files/adblock.sh
@@ -4,7 +4,7 @@
# This is free software, licensed under the GNU General Public License v3.
# set (s)hellcheck exceptions
-# shellcheck disable=1091,2010,2016,2034,2039,2059,2086,2091,2129,2143,2154,2181,2183,2188
+# shellcheck disable=1091,2010,2016,2034,2039,2059,2086,2091,2129,2143,2154,2181,2183,2188,3040,3043,3060
# set initial defaults
#
@@ -316,7 +316,7 @@ f_dns()
adb_dnsinstance="${adb_dnsinstance:-"0"}"
adb_dnsuser="${adb_dnsuser:-"dnsmasq"}"
adb_dnsdir="${adb_dnsdir:-"/tmp/dnsmasq.d"}"
- adb_dnsheader="${adb_dnsheader}"
+ adb_dnsheader="${adb_dnsheader:-""}"
adb_dnsdeny="${adb_dnsdeny:-"${adb_awk} '{print \"address=/\"\$0\"/\"}'"}"
adb_dnsallow="${adb_dnsallow:-"${adb_awk} '{print \"local=/\"\$0\"/#\"}'"}"
adb_dnssafesearch="${adb_dnssafesearch:-"${adb_awk} -v item=\"\$item\" '{print \"address=/\"\$0\"/\"item\"\"}'"}"
@@ -328,7 +328,7 @@ f_dns()
adb_dnsinstance="${adb_dnsinstance:-"0"}"
adb_dnsuser="${adb_dnsuser:-"unbound"}"
adb_dnsdir="${adb_dnsdir:-"/var/lib/unbound"}"
- adb_dnsheader="${adb_dnsheader}"
+ adb_dnsheader="${adb_dnsheader:-""}"
adb_dnsdeny="${adb_dnsdeny:-"${adb_awk} '{print \"local-zone: \\042\"\$0\"\\042 static\"}'"}"
adb_dnsallow="${adb_dnsallow:-"${adb_awk} '{print \"local-zone: \\042\"\$0\"\\042 transparent\"}'"}"
adb_dnssafesearch="${adb_dnssafesearch:-"${adb_awk} -v item=\"\$item\" '{type=\"AAAA\";if(match(item,/^([0-9]{1,3}\.){3}[0-9]{1,3}$/)){type=\"A\"}}{print \"local-data: \\042\"\$0\" \"type\" \"item\"\\042\"}'"}"
@@ -366,7 +366,7 @@ f_dns()
adb_dnsinstance="${adb_dnsinstance:-"0"}"
adb_dnsuser="${adb_dnsuser:-"root"}"
adb_dnsdir="${adb_dnsdir:-"/tmp"}"
- adb_dnsheader="${adb_dnsheader}"
+ adb_dnsheader="${adb_dnsheader:-""}"
adb_dnsdeny="${adb_dnsdeny:-"0"}"
adb_dnsallow="${adb_dnsallow:-"1"}"
adb_dnssafesearch="${adb_dnssafesearch:-"0"}"
@@ -1293,9 +1293,9 @@ f_jsnup()
memory="$("${adb_awk}" '/^MemTotal|^MemFree|^MemAvailable/{ORS="/"; print int($2/1000)}' "/proc/meminfo" 2>/dev/null | "${adb_awk}" '{print substr($0,1,length($0)-1)}')"
if [ "$(( (adb_endtime-adb_starttime)/60 ))" -lt 60 ]
then
- runtime="${adb_action}, $(( (adb_endtime-adb_starttime)/60 ))m $(( (adb_endtime-adb_starttime)%60 ))s, ${memory:-0}, $(date "+%d.%m.%Y %H:%M:%S")"
+ runtime="${adb_action}, $(( (adb_endtime-adb_starttime)/60 ))m $(( (adb_endtime-adb_starttime)%60 ))s, ${memory:-0}, $(date -Iseconds)"
else
- runtime="${adb_action}, n/a, ${memory:-0}, $(date "+%d.%m.%Y %H:%M:%S")"
+ runtime="${adb_action}, n/a, ${memory:-0}, $(date -Iseconds)"
fi
if [ "${status}" = "error" ]
then
diff --git a/net/adblock/files/adblock.sources b/net/adblock/files/adblock.sources
index c1d073b84..59df5c444 100644
--- a/net/adblock/files/adblock.sources
+++ b/net/adblock/files/adblock.sources
@@ -40,7 +40,7 @@
"size": "L",
"focus": "compilation",
"descurl": "https://github.com/privacy-protection-tools/anti-AD/blob/master/README.md"
- },
+ },
"anudeep": {
"url": "https://raw.githubusercontent.com/anudeepND/blacklist/master/adservers.txt",
"rule": "/^0\\.0\\.0\\.0[[:space:]]+([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($2)}",
@@ -83,6 +83,13 @@
"focus": "tracking",
"descurl": "https://www.gameindustry.eu"
},
+ "hblock": {
+ "url": "https://hblock.molinero.dev/hosts_domains.txt",
+ "rule": "/^([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
+ "size": "XL",
+ "focus": "compilation",
+ "descurl": "https://hblock.molinero.dev"
+ },
"notracking": {
"url": "https://raw.githubusercontent.com/notracking/hosts-blocklists/master/dnscrypt-proxy/dnscrypt-proxy.blacklist.txt",
"rule": "/^([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
@@ -253,7 +260,7 @@
},
"stopforumspam": {
"url": "https://www.stopforumspam.com/downloads/toxic_domains_whole.txt",
- "rule": "/^[[:space:]]*([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
+ "rule": "/^([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
"size": "S",
"focus": "spam",
"descurl": "https://www.stopforumspam.com"