aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Moeller <moeller0@gmx.de>2015-06-29 10:29:34 +0200
committerToke Høiland-Jørgensen <toke@toke.dk>2015-07-12 22:24:21 +0200
commit517954b7f5b57f48ecc21033f8b74fc7cc20eeb3 (patch)
tree9926b3ee09a006c012d6fef7b2737ff303592d02
parent034e4d24754682fff71fcfb6ac425b1b4e147532 (diff)
[SQM] Fix simple.qos to allow using cake as ingress shaper
simple.qos had accidentally set up the egress shaper twice, once with the true egress parameters and a second time using the ingress parameters, effectively misconfiguring both directions. This bub only affected situations where 3-tier ingress classification was used. Signed-off-by: Sebastian Moeller <moeller0@gmx.de>
-rw-r--r--net/sqm-scripts/Makefile2
-rwxr-xr-xnet/sqm-scripts/files/usr/lib/sqm/simple.qos2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/sqm-scripts/Makefile b/net/sqm-scripts/Makefile
index b65905cf4..6a5848137 100644
--- a/net/sqm-scripts/Makefile
+++ b/net/sqm-scripts/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sqm-scripts
PKG_VERSION:=8
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_LICENSE:=GPLv2
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/net/sqm-scripts/files/usr/lib/sqm/simple.qos b/net/sqm-scripts/files/usr/lib/sqm/simple.qos
index e1ce37266..5a36df1cf 100755
--- a/net/sqm-scripts/files/usr/lib/sqm/simple.qos
+++ b/net/sqm-scripts/files/usr/lib/sqm/simple.qos
@@ -177,7 +177,7 @@ else
sqm_logger "Perform DSCP based filtering on ingress. (3-tier classification)"
case $QDISC in
cake*)
- $TC qdisc add dev $IFACE root `get_stab_string` $QDISC bandwidth ${DOWNLINK}kbit `get_cake_lla_string` $CAKE_OPTS ${IQDISC_OPTS}
+ $TC qdisc add dev $DEV root `get_stab_string` $QDISC bandwidth ${DOWNLINK}kbit `get_cake_lla_string` $CAKE_OPTS ${IQDISC_OPTS}
;;
*)
$TC qdisc add dev $DEV root handle 1: `get_stab_string` htb default 12