aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2015-07-16 17:18:28 -0400
committerTed Hess <thess@kitschensync.net>2015-07-16 17:18:28 -0400
commit513297103d6d101109ea0de4054bb40761a0f9a1 (patch)
tree35ae9a82dc8e5037bd9f5ec4a5246b5906b67ae9
parent480be2b2d407a8e151dae8c434b1c472a5474ccb (diff)
parentfce4da5b67266572825187090cb88a21b1465959 (diff)
Merge pull request #1578 from tru7/pthsem
pthsem: fix signal.h include path
-rw-r--r--libs/pthsem/Makefile2
-rw-r--r--libs/pthsem/patches/002-fix-signal.h22
2 files changed, 23 insertions, 1 deletions
diff --git a/libs/pthsem/Makefile b/libs/pthsem/Makefile
index 54d7737e1..5d3effbba 100644
--- a/libs/pthsem/Makefile
+++ b/libs/pthsem/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pthsem
PKG_VERSION:=2.0.8
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
PKG_LICENSE:=LGPL-2.1+
diff --git a/libs/pthsem/patches/002-fix-signal.h b/libs/pthsem/patches/002-fix-signal.h
new file mode 100644
index 000000000..0e4fdfc7f
--- /dev/null
+++ b/libs/pthsem/patches/002-fix-signal.h
@@ -0,0 +1,22 @@
+--- a/pth.h.in 2015-07-16 21:14:48.786970549 +0200
++++ b/pth.h.in 2015-07-16 21:15:22.439416462 +0200
+@@ -43,7 +43,7 @@
+ #include <time.h> /* for struct timespec */
+ #include <sys/time.h> /* for struct timeval */
+ #include <sys/socket.h> /* for sockaddr */
+-#include <sys/signal.h> /* for sigset_t */
++#include <signal.h> /* for sigset_t */
+ @EXTRA_INCLUDE_SYS_SELECT_H@
+
+ /* fallbacks for essential typedefs */
+--- a/pthread.h.in 2015-07-16 21:14:58.948310639 +0200
++++ b/pthread.h.in 2015-07-16 21:15:40.989869061 +0200
+@@ -111,7 +111,7 @@
+ #include <sys/types.h> /* for ssize_t */
+ #include <sys/time.h> /* for struct timeval */
+ #include <sys/socket.h> /* for sockaddr */
+-#include <sys/signal.h> /* for sigset_t */
++#include <signal.h> /* for sigset_t */
+ #include <time.h> /* for struct timespec */
+ #include <unistd.h> /* for off_t */
+ @EXTRA_INCLUDE_SYS_SELECT_H@