aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2024-03-23 19:22:13 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2024-03-24 10:15:42 +0100
commit50dffb7424989902931ddb0c701cd21c0bb835ff (patch)
tree28482a8aaa2045d70c6687bd8431ea9bd9b5dd54
parentd4ef5bb60ddfcf8b399ffb8b2b8e8dfe17382394 (diff)
snort3: Fix compilation with GCC 13
This fixes a compile problem with GCC 13. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
2 files changed, 23 insertions, 1 deletions
diff --git a/net/snort3/Makefile b/net/snort3/Makefile
index ba485d253..e895399ef 100644
--- a/net/snort3/Makefile
+++ b/net/snort3/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=snort3
PKG_VERSION:=3.1.82.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/snort3/snort3/archive/refs/tags/
diff --git a/net/snort3/patches/110-packet_capture-Fix-compilation-with-GCC-13.patch b/net/snort3/patches/110-packet_capture-Fix-compilation-with-GCC-13.patch
new file mode 100644
index 000000000..a1b4eb583
--- /dev/null
+++ b/net/snort3/patches/110-packet_capture-Fix-compilation-with-GCC-13.patch
@@ -0,0 +1,22 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Sat, 23 Mar 2024 19:11:15 +0100
+Subject: packet_capture: Fix compilation with GCC 13
+
+Fix the following compile problem with GCC 13:
+src/network_inspectors/packet_capture/packet_capture.h:25:54: error: 'int16_t' does not name a type
+ 25 | void packet_capture_enable(const std::string&, const int16_t g = -1, const std::string& t = "");
+---
+ src/network_inspectors/packet_capture/packet_capture.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/network_inspectors/packet_capture/packet_capture.h
++++ b/src/network_inspectors/packet_capture/packet_capture.h
+@@ -21,6 +21,7 @@
+ #define PACKET_CAPTURE_H
+
+ #include <string>
++#include <cstdint>
+
+ void packet_capture_enable(const std::string&, const int16_t g = -1, const std::string& t = "");
+ void packet_capture_disable();