aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-14 10:00:49 -0800
committerRosen Penev <rosenp@gmail.com>2018-11-14 10:00:49 -0800
commit509ed2121ba67cc71bc17afd04e01e32d90ea66a (patch)
treeed71ba39be4a83c17498d6da8feb398d45f522bf
parentc0b1527c35636e286e8074441b11dbcdd580769f (diff)
python-pycparser: Update to 2.19
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--lang/python/python-pycparser/Makefile9
-rw-r--r--lang/python/python-pycparser/patches/001-use-external-ply.patch14
2 files changed, 8 insertions, 15 deletions
diff --git a/lang/python/python-pycparser/Makefile b/lang/python/python-pycparser/Makefile
index 9a8b65cae..61fb1a963 100644
--- a/lang/python/python-pycparser/Makefile
+++ b/lang/python/python-pycparser/Makefile
@@ -8,13 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-pycparser
-PKG_VERSION:=2.18
-PKG_RELEASE:=2
+PKG_VERSION:=2.19
+PKG_RELEASE:=1
PKG_SOURCE:=pycparser-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/8c/2d/aad7f16146f4197a11f8e91fb81df177adcc2073d36a17b1491fd09df6ed
-PKG_HASH:=99a8ca03e29851d96616ad0404b4aad7d9ee16f25c9f9708a11faf2810f7b226
-
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/p/pycparser
+PKG_HASH:=a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-pycparser-$(PKG_VERSION)
PKG_LICENSE:=BSD-3-Clause
diff --git a/lang/python/python-pycparser/patches/001-use-external-ply.patch b/lang/python/python-pycparser/patches/001-use-external-ply.patch
index 96b1d0343..23c43d280 100644
--- a/lang/python/python-pycparser/patches/001-use-external-ply.patch
+++ b/lang/python/python-pycparser/patches/001-use-external-ply.patch
@@ -1,5 +1,3 @@
-diff --git a/pycparser/c_lexer.py b/pycparser/c_lexer.py
-index cbb9d26..cbd7742 100644
--- a/pycparser/c_lexer.py
+++ b/pycparser/c_lexer.py
@@ -9,8 +9,8 @@
@@ -13,8 +11,6 @@ index cbb9d26..cbd7742 100644
class CLexer(object):
-diff --git a/pycparser/c_parser.py b/pycparser/c_parser.py
-index f4f7453..5c0ca88 100644
--- a/pycparser/c_parser.py
+++ b/pycparser/c_parser.py
@@ -8,7 +8,7 @@
@@ -26,14 +22,12 @@ index f4f7453..5c0ca88 100644
from . import c_ast
from .c_lexer import CLexer
-diff --git a/setup.py b/setup.py
-index fdccbb3..036a10b 100644
--- a/setup.py
+++ b/setup.py
-@@ -49,7 +49,7 @@ setup(
- classifiers = [
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 3',],
+@@ -60,7 +60,7 @@ setup(
+ 'Programming Language :: Python :: 3.6',
+ ],
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
- packages=['pycparser', 'pycparser.ply'],
+ packages=['pycparser'],
package_data={'pycparser': ['*.cfg']},