aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-12-03 05:42:28 +0100
committerAlexander Couzens <lynxis@fe80.eu>2017-12-10 02:26:10 +0100
commit4e500f91dd79c2982c185bc047d9c1d19121de9b (patch)
treecd823b352db08e8fd367d9cb23cc5e3b4b5db422
parent411b85b664e39d7646c52d75a915b75520661b93 (diff)
open-plc-utils: remove build timestamp
Build timestamps prevent reproducible builds [0]. [0] https://reproducible-builds.org/docs/timestamps/ Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
-rw-r--r--utils/open-plc-utils/Makefile4
-rw-r--r--utils/open-plc-utils/patches/100-remove-build-timestamp.patch37
2 files changed, 39 insertions, 2 deletions
diff --git a/utils/open-plc-utils/Makefile b/utils/open-plc-utils/Makefile
index 2123502c0..092025ec9 100644
--- a/utils/open-plc-utils/Makefile
+++ b/utils/open-plc-utils/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=open-plc-utils
-PKG_VERSION:=2017-01-15
+PKG_VERSION:=2017-12-03
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=18b7e2a9a17f043fe8ac8b457680aafb1c249c55
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
-PKG_MIRROR_HASH:=fd898954f3a7f4f1f1b02a61b748546d648e323642c004353aeb4b337dbaa5dc
+PKG_MIRROR_HASH:=8ccbee8a6eb9a9be97bab74e02033cdb57456ae5f78fd3b19a3661352b89e259
PKG_MAINTAINER:=Florian Fainelli <florian@openwrt.org>
diff --git a/utils/open-plc-utils/patches/100-remove-build-timestamp.patch b/utils/open-plc-utils/patches/100-remove-build-timestamp.patch
new file mode 100644
index 000000000..57d5eeeaa
--- /dev/null
+++ b/utils/open-plc-utils/patches/100-remove-build-timestamp.patch
@@ -0,0 +1,37 @@
+Index: open-plc-utils-2017-01-15/docbook/version.h.html
+===================================================================
+--- open-plc-utils-2017-01-15.orig/docbook/version.h.html 2017-01-13 19:44:27.000000000 +0100
++++ open-plc-utils-2017-01-15/docbook/version.h.html 2017-12-03 03:46:31.119387280 +0100
+@@ -40,7 +40,6 @@
+ #define PROJECT &quot;open-plc-utils&quot;
+ #define VERSION &quot;0.0.6&quot;
+ #define RELEASE &quot;OSRQCA-929&quot;
+-#define COMPILE __TIME__ &quot; &quot; __DATE__
+ #define CONTACT &quot;cmaier@qca.qualcomm.com&quot;
+ #define LICENSE &quot;Clear BSD&quot;
+
+Index: open-plc-utils-2017-01-15/tools/version.c
+===================================================================
+--- open-plc-utils-2017-01-15.orig/tools/version.c 2017-01-13 19:44:27.000000000 +0100
++++ open-plc-utils-2017-01-15/tools/version.c 2017-12-03 03:45:57.358690651 +0100
+@@ -30,7 +30,6 @@
+ printf (RELEASE " ");
+ printf ("ISO C ");
+- printf (COMPANY " ");
++ printf (COMPANY "\n");
+- printf (COMPILE "\n");
+ return;
+ }
+
+Index: open-plc-utils-2017-01-15/tools/version.h
+===================================================================
+--- open-plc-utils-2017-01-15.orig/tools/version.h 2017-01-13 19:44:27.000000000 +0100
++++ open-plc-utils-2017-01-15/tools/version.h 2017-12-03 03:46:08.902929217 +0100
+@@ -20,7 +20,6 @@
+ #define PROJECT "open-plc-utils"
+ #define VERSION "0.0.6"
+ #define RELEASE "OSRQCA-929"
+-#define COMPILE __TIME__ " " __DATE__
+ #define CONTACT "https://github.com/qca/open-plc-utils"
+ #define LICENSE "Clear BSD"
+