aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-07-15 16:01:53 -0700
committerRosen Penev <rosenp@gmail.com>2019-11-04 12:05:27 -0800
commit4e23b0fcf69e06633649c9ac6c724622a9d69b6c (patch)
tree93f2a7a48b084e8a34f8bbe802d8c15810f371aa
parent98c04e04c48c6339fb6310844b5e159e83f1b81a (diff)
Netopeer2: Update to 0.7-r2
Small cleanups. Removed upstreamed patch. Suffixed all patches with .patch Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--net/Netopeer2/Makefile10
-rw-r--r--net/Netopeer2/patches/001-fix-for-cmake-build.patch (renamed from net/Netopeer2/patches/001-fix-for-cmake-build)31
-rw-r--r--net/Netopeer2/patches/002-fix-keystored-cross-compile.patch (renamed from net/Netopeer2/patches/002-fix-keystored-cross-compile)8
-rw-r--r--net/Netopeer2/patches/010-openssl-deprecated.patch14
4 files changed, 19 insertions, 44 deletions
diff --git a/net/Netopeer2/Makefile b/net/Netopeer2/Makefile
index 1eb1b68e1..db6fd8d46 100644
--- a/net/Netopeer2/Makefile
+++ b/net/Netopeer2/Makefile
@@ -10,19 +10,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=Netopeer2
-PKG_VERSION:=0.7-r1
-PKG_RELEASE:=3
+PKG_VERSION:=0.7-r2
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/CESNET/Netopeer2/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=040013d1e315c62c496b704475665165578c374ffb387cbbff422cf8898d3a12
+PKG_HASH:=59688271be4fecbbee671fc7eb3dc0538b13b4baab53e923e26eaeb33e6f7ec0
PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
-PKG_BUILD_PARALLEL:=1
CMAKE_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -65,8 +65,6 @@ define Package/netopeer2/description
endef
CMAKE_OPTIONS += \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DCMAKE_BUILD_TYPE:STRING=Release \
-DKEYSTORED_KEYS_DIR:STRING=/etc/keystored/keys \
-DENABLE_CONFIGURATION:BOOL=OFF \
-DMODEL_INSTALL:BOOL=OFF \
diff --git a/net/Netopeer2/patches/001-fix-for-cmake-build b/net/Netopeer2/patches/001-fix-for-cmake-build.patch
index 3dae3caa5..ce69ee3a2 100644
--- a/net/Netopeer2/patches/001-fix-for-cmake-build
+++ b/net/Netopeer2/patches/001-fix-for-cmake-build.patch
@@ -1,17 +1,13 @@
-Index: Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/CMakeLists.txt
-===================================================================
--- /dev/null
-+++ Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -0,0 +1,5 @@
+cmake_minimum_required(VERSION 2.6)
+
+add_subdirectory(server)
+add_subdirectory(cli)
+add_subdirectory(keystored)
-Index: Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/cli/CMakeLists.txt
-===================================================================
---- Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d.orig/cli/CMakeLists.txt
-+++ Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/cli/CMakeLists.txt
+--- a/cli/CMakeLists.txt
++++ b/cli/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6)
@@ -21,7 +17,7 @@ Index: Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/cli/CMakeLists.
project(netopeer2-cli C)
include(GNUInstallDirs)
-@@ -83,7 +83,7 @@ endif()
+@@ -84,7 +84,7 @@ endif()
install(FILES ${PROJECT_SOURCE_DIR}/doc/${PROJECT_NAME}.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
# clean cmake cache
@@ -30,10 +26,8 @@ Index: Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/cli/CMakeLists.
COMMAND make clean
COMMAND find . -iname '*cmake*' -not -name CMakeLists.txt -exec rm -rf {} +
COMMAND rm -rf Makefile Doxyfile
-Index: Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/keystored/CMakeLists.txt
-===================================================================
---- Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d.orig/keystored/CMakeLists.txt
-+++ Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/keystored/CMakeLists.txt
+--- a/keystored/CMakeLists.txt
++++ b/keystored/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6)
@@ -43,7 +37,7 @@ Index: Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/keystored/CMake
project(keystored C)
include(GNUInstallDirs)
-@@ -140,7 +140,7 @@ if (SSH_KEY_INSTALL)
+@@ -147,7 +147,7 @@ if (SSH_KEY_INSTALL)
execute_process(COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/scripts/ssh-key-import.sh)")
endif()
@@ -52,10 +46,8 @@ Index: Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/keystored/CMake
scripts/model-install.sh
scripts/ssh-key-import.sh
)
-Index: Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/server/CMakeLists.txt
-===================================================================
---- Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d.orig/server/CMakeLists.txt
-+++ Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/server/CMakeLists.txt
+--- a/server/CMakeLists.txt
++++ b/server/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.8.9)
@@ -65,11 +57,12 @@ Index: Netopeer2-0.4.13-ae560bef2e70d274f6d028b59e3cb398ea2a621d/server/CMakeLis
project(netopeer2-server C)
include(GNUInstallDirs)
-@@ -204,7 +204,7 @@ if (ENABLE_CONFIGURATION)
+@@ -208,7 +208,7 @@ if (ENABLE_CONFIGURATION)
execute_process(COMMAND ${PROJECT_BINARY_DIR}/model-install.sh)")
endif()
-
+
-add_custom_target(install-scripts-ide
+add_custom_target(install-scripts-ide-server
${PROJECT_BINARY_DIR}/model-install.sh
)
+
diff --git a/net/Netopeer2/patches/002-fix-keystored-cross-compile b/net/Netopeer2/patches/002-fix-keystored-cross-compile.patch
index 11301e768..db30cd421 100644
--- a/net/Netopeer2/patches/002-fix-keystored-cross-compile
+++ b/net/Netopeer2/patches/002-fix-keystored-cross-compile.patch
@@ -1,7 +1,5 @@
-Index: Netopeer2-0.6-r1/keystored/CMakeLists.txt
-===================================================================
---- Netopeer2-0.6-r1.orig/keystored/CMakeLists.txt
-+++ Netopeer2-0.6-r1/keystored/CMakeLists.txt
+--- a/keystored/CMakeLists.txt
++++ b/keystored/CMakeLists.txt
@@ -69,6 +69,8 @@ find_package(SYSREPO REQUIRED)
target_link_libraries(keystored ${SYSREPO_LIBRARIES})
include_directories(${SYSREPO_INCLUDE_DIRS})
@@ -11,7 +9,7 @@ Index: Netopeer2-0.6-r1/keystored/CMakeLists.txt
# get sysrepo plugins directory
if (NOT SR_PLUGINS_DIR)
if (PKG_CONFIG_FOUND)
-@@ -154,3 +156,4 @@ add_custom_target(install-scripts-ide-ke
+@@ -154,3 +156,4 @@ add_custom_target(install-scripts-ide
# plugins should be installed into sysrepo plugins dir
install(TARGETS keystored DESTINATION ${SR_PLUGINS_DIR})
diff --git a/net/Netopeer2/patches/010-openssl-deprecated.patch b/net/Netopeer2/patches/010-openssl-deprecated.patch
deleted file mode 100644
index b0a9f4f06..000000000
--- a/net/Netopeer2/patches/010-openssl-deprecated.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/cli/commands.c
-+++ b/cli/commands.c
-@@ -1659,7 +1659,11 @@ parse_cert(const char *name, const char *path)
- BIO_printf(bio_out, "\n");
-
- BIO_printf(bio_out, "Valid until: ");
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L // < 1.1.0
- ASN1_TIME_print(bio_out, X509_get_notAfter(cert));
-+#else
-+ ASN1_TIME_print(bio_out, X509_get0_notAfter(cert));
-+#endif
- BIO_printf(bio_out, "\n");
-
- has_san = 0;