aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2017-07-04 22:31:48 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2017-07-19 16:51:38 +0300
commit4bec8be1305183b168b78e81de2d327c5155c2e6 (patch)
tree88fa88b1b73b72b8d23be47e8880db72a6ec05be
parentc188fcfb7c4fdd9f715db872f038f4ff3bf00404 (diff)
python-ply: bump to version 3.10 and drop the host-build
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
-rw-r--r--lang/python/python-ply/Makefile50
1 files changed, 10 insertions, 40 deletions
diff --git a/lang/python/python-ply/Makefile b/lang/python/python-ply/Makefile
index 61b34a312..212fdb03b 100644
--- a/lang/python/python-ply/Makefile
+++ b/lang/python/python-ply/Makefile
@@ -7,34 +7,26 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=ply
-PKG_VERSION:=3.9
-PKG_RELEASE:=2
+PKG_NAME:=python-ply
+PKG_VERSION:=3.10
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=ply-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.dabeaz.com/ply
-PKG_HASH:=0d7e2940b9c57151392fceaa62b0865c45e06ce1e36687fd8d03f011a907f43e
+PKG_HASH:=96e94af7dd7031d8d6dd6e2a8e0de593b511c211a86e28a9c9621c275ac8bacb
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-$(PKG_NAME)-$(PKG_VERSION)
-PKG_UNPACK=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
-
-HOST_BUILD_DEPENDS:=
-ifdef CONFIG_PACKAGE_python-ply
-HOST_BUILD_DEPENDS+=python/host
-endif
-ifdef CONFIG_PACKAGE_python3-ply
-HOST_BUILD_DEPENDS+=python3/host
-endif
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-ply-$(PKG_VERSION)
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=README.md
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
-include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python-package.mk)
$(call include_mk, python3-package.mk)
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
define Package/python-ply/Default
SECTION:=lang
CATEGORY:=Languages
@@ -45,14 +37,14 @@ endef
define Package/python-ply
$(call Package/python-ply/Default)
TITLE:=python-ply
- DEPENDS:=+python-light
+ DEPENDS:=+PACKAGE_python-ply:python-light
VARIANT:=python
endef
define Package/python3-ply
$(call Package/python-ply/Default)
TITLE:=python3-ply
- DEPENDS:=+python3-light
+ DEPENDS:=+PACKAGE_python3-ply:python3-light
VARIANT:=python3
endef
@@ -67,28 +59,6 @@ $(call Package/python-ply/description)
(Variant for Python3)
endef
-ifdef CONFIG_PACKAGE_python-ply
-define Host/Compile/python-ply
- $(call Build/Compile/HostPyMod,,install --prefix="" --root="$(STAGING_DIR_HOSTPKG)")
-endef
-endif
-
-ifdef CONFIG_PACKAGE_python3-ply
-define Host/Compile/python3-ply
- $(call Build/Compile/HostPy3Mod,,install --prefix="" --root="$(STAGING_DIR_HOSTPKG)")
-endef
-endif
-
-define Host/Compile
-$(call Host/Compile/python-ply)
-$(call Host/Compile/python3-ply)
-endef
-
-define Host/Install
-endef
-
-$(eval $(call HostBuild))
-
$(eval $(call PyPackage,python-ply))
$(eval $(call BuildPackage,python-ply))