aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2021-12-03 05:41:40 +0100
committerGitHub <noreply@github.com>2021-12-03 05:41:40 +0100
commit4be2a5b73757eb0037d41da962518eaac4e4d3ac (patch)
tree6f8af77550026ece7979809020973755e30b8828
parent189a806293e3594da07d47bdec120d92014b2a8f (diff)
parent1441366364effa0c90aca739fd05699f2f3c8d57 (diff)
Merge pull request #17137 from oskarirauta/banip
banip: update nginx matching
-rw-r--r--net/banip/Makefile2
-rwxr-xr-xnet/banip/files/banip.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/banip/Makefile b/net/banip/Makefile
index ca159c3ed..c210c96a5 100644
--- a/net/banip/Makefile
+++ b/net/banip/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=banip
PKG_VERSION:=0.7.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/banip/files/banip.sh b/net/banip/files/banip.sh
index 34ebe5e46..8672ead22 100755
--- a/net/banip/files/banip.sh
+++ b/net/banip/files/banip.sh
@@ -813,7 +813,7 @@ f_bgsrv() {
ban_search="${ban_search}luci: failed login|"
fi
if printf "%s\n" "${ban_logterms}" | grep -q "nginx"; then
- ban_search="${ban_search}nginx\[[0-9]+\]:.*\[error\].*open().*client: [[:alnum:].:]+|"
+ ban_search="${ban_search}nginx(\[[0-9]+\])?:.*\[error\].*open().*client: [[:alnum:].:]+|"
fi
(
"${ban_logservice}" "${ban_search%?}" &