aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2021-02-22 23:44:53 -0300
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>2021-02-23 00:24:08 -0300
commit49e75e810585a1e173e74fe3b7154a65835675c7 (patch)
treeea1cbd46888e3c24a54d24538a4d8e2bc34c2e8c
parent9543f72c7755e87686c5ac1e46565d8268d1d0ff (diff)
sane-backends: update to 1.0.32
Dropped 102-pixma_Restore_old_behaviour_in_case_XML_support_is_missing.patch (merged) Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
3 files changed, 5 insertions, 104 deletions
diff --git a/utils/sane-backends/Makefile b/utils/sane-backends/Makefile
index ab53eff9e..214e2269d 100644
--- a/utils/sane-backends/Makefile
+++ b/utils/sane-backends/Makefile
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sane-backends
-PKG_VERSION:=1.0.31
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.32
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/8bf1cae2e1803aefab9e5331550e5d5d/
-PKG_HASH:=4a3b10fcb398ed854777d979498645edfe66fcac2f2fd2b9117a79ff45e2a5aa
+PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/104f09c07d35519cc8e72e604f11643f
+PKG_HASH:=3a28c237c0a72767086202379f6dc92dbb63ec08dfbab22312cba80e238bb114
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=GPL-2.0 GPL-2.0-or-later
diff --git a/utils/sane-backends/patches/002-remove-uneeded.patch b/utils/sane-backends/patches/002-remove-uneeded.patch
index e02eed073..65d9cea17 100644
--- a/utils/sane-backends/patches/002-remove-uneeded.patch
+++ b/utils/sane-backends/patches/002-remove-uneeded.patch
@@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -442,7 +442,7 @@ target_alias = @target_alias@
+@@ -451,7 +451,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
diff --git a/utils/sane-backends/patches/102-pixma_Restore_old_behaviour_in_case_XML_support_is_missing.patch b/utils/sane-backends/patches/102-pixma_Restore_old_behaviour_in_case_XML_support_is_missing.patch
deleted file mode 100644
index a2518b7d1..000000000
--- a/utils/sane-backends/patches/102-pixma_Restore_old_behaviour_in_case_XML_support_is_missing.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-From a380fb089499f6b5192c07ae2feaa3376997382f Mon Sep 17 00:00:00 2001
-From: Olaf Meeuwissen <paddy-hack@member.fsf.org>
-Date: Sun, 13 Sep 2020 18:47:32 +0900
-Subject: [PATCH] pixma: Restore old behaviour in case XML support is missing
-
-Fixes #345.
----
- backend/pixma/pixma_common.c | 4 ++--
- backend/pixma/pixma_common.h | 2 ++
- backend/pixma/pixma_mp150.c | 8 ++++++++
- backend/pixma/pixma_mp800.c | 8 ++++++++
- 4 files changed, 20 insertions(+), 2 deletions(-)
-
---- a/backend/pixma/pixma_common.c
-+++ b/backend/pixma/pixma_common.c
-@@ -56,8 +56,6 @@
-
- #if defined(HAVE_LIBXML2)
- # include <libxml/parser.h>
--#else
--# error "The pixma backend requires libxml2"
- #endif
-
- #include "pixma_rename.h"
-@@ -1241,6 +1239,7 @@ pixma_get_device_status (pixma_t * s, pi
- return s->ops->get_status (s, status);
- }
-
-+#if defined(HAVE_LIBXML2)
- static const char *
- format_xml_response(const char *resp_details)
- {
-@@ -1334,3 +1333,4 @@ clean:
- xmlFreeDoc(doc);
- return status;
- }
-+#endif
---- a/backend/pixma/pixma_common.h
-+++ b/backend/pixma/pixma_common.h
-@@ -205,7 +205,9 @@ uint8_t *pixma_newcmd (pixma_cmdbuf_t *,
- int pixma_exec (pixma_t *, pixma_cmdbuf_t *);
- int pixma_exec_short_cmd (pixma_t *, pixma_cmdbuf_t *, unsigned cmd);
- int pixma_map_status_errno (unsigned status);
-+#if defined(HAVE_LIBXML2)
- int pixma_parse_xml_response(const char *xml_message);
-+#endif
- /**@}*/
-
- #define pixma_fill_checksum(start, end) do { \
---- a/backend/pixma/pixma_mp150.c
-+++ b/backend/pixma/pixma_mp150.c
-@@ -322,6 +322,10 @@
- <ivec:param_set servicetype=\"scan\"><ivec:jobID>00000001</ivec:jobID>\
- </ivec:param_set></ivec:contents></cmd>"
-
-+#if !defined(HAVE_LIBXML2)
-+#define XML_OK "<ivec:response>OK</ivec:response>"
-+#endif
-+
- enum mp150_state_t
- {
- state_idle,
-@@ -459,7 +463,11 @@ send_xml_dialog (pixma_t * s, const char
- PDBG (pixma_dbg (10, "XML message sent to scanner:\n%s\n", xml_message));
- PDBG (pixma_dbg (10, "XML response back from scanner:\n%s\n", mp->cb.buf));
-
-+#if defined(HAVE_LIBXML2)
- return pixma_parse_xml_response((const char*)mp->cb.buf) == PIXMA_STATUS_OK;
-+#else
-+ return (strcasestr ((const char *) mp->cb.buf, XML_OK) != NULL);
-+#endif
- }
-
- static int
---- a/backend/pixma/pixma_mp800.c
-+++ b/backend/pixma/pixma_mp800.c
-@@ -152,6 +152,10 @@
- <ivec:param_set servicetype=\"scan\"><ivec:jobID>00000001</ivec:jobID>\
- </ivec:param_set></ivec:contents></cmd>"
-
-+#if !defined(HAVE_LIBXML2)
-+#define XML_OK "<ivec:response>OK</ivec:response>"
-+#endif
-+
- enum mp810_state_t
- {
- state_idle,
-@@ -291,7 +295,11 @@ static int send_xml_dialog (pixma_t * s,
- PDBG(pixma_dbg (10, "XML message sent to scanner:\n%s\n", xml_message));
- PDBG(pixma_dbg (10, "XML response back from scanner:\n%s\n", mp->cb.buf));
-
-+#if defined(HAVE_LIBXML2)
- return pixma_parse_xml_response((const char*)mp->cb.buf) == PIXMA_STATUS_OK;
-+#else
-+ return (strcasestr ((const char *) mp->cb.buf, XML_OK) != NULL);
-+#endif
- }
-
- static void new_cmd_tpu_msg (pixma_t *s, pixma_cmdbuf_t * cb, uint16_t cmd)