aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-11-18 21:25:56 +0200
committerGitHub <noreply@github.com>2018-11-18 21:25:56 +0200
commit49adfe3d32ceabe9d0ae25cfff77f1f327ea7a11 (patch)
tree763c29d748c574a872edca7c2072dbab53160f38
parentc2212e8d64c0d709d54d634ee7a5df1651722eb3 (diff)
parent12378ef296d4e20627f548a66a7fb2f0ceb4c27c (diff)
Merge pull request #7370 from neheb/light
lighttpd: Fix Compilation with OpenSSL 1.1.x
-rw-r--r--net/lighttpd/Makefile2
-rw-r--r--net/lighttpd/patches/010-openssl-deprecated.patch14
2 files changed, 15 insertions, 1 deletions
diff --git a/net/lighttpd/Makefile b/net/lighttpd/Makefile
index cb0ab7d7f..afe7a4a78 100644
--- a/net/lighttpd/Makefile
+++ b/net/lighttpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lighttpd
PKG_VERSION:=1.4.49
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
diff --git a/net/lighttpd/patches/010-openssl-deprecated.patch b/net/lighttpd/patches/010-openssl-deprecated.patch
new file mode 100644
index 000000000..0b2176bfd
--- /dev/null
+++ b/net/lighttpd/patches/010-openssl-deprecated.patch
@@ -0,0 +1,14 @@
+diff --git a/src/rand.c b/src/rand.c
+index 10cd025..63fbb0d 100644
+--- a/src/rand.c
++++ b/src/rand.c
+@@ -226,7 +226,9 @@ int li_rand_bytes (unsigned char *buf, int num)
+ void li_rand_cleanup (void)
+ {
+ #ifdef USE_OPENSSL_CRYPTO
++ #if OPENSSL_VERSION_NUMBER < 0x10100000L
+ RAND_cleanup();
++ #endif
+ #endif
+ safe_memclear(xsubi, sizeof(xsubi));
+ }