aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-05-23 21:16:25 -0700
committerRosen Penev <rosenp@gmail.com>2020-05-24 18:36:13 -0700
commit499564b1d120a3bbd60886faaa2ac8350b5f68a3 (patch)
tree8a814163215643d67ca0fc6f67c0862001310000
parentf50e2bde1dcf55f6eba7b27fc6f89ed3fd2496d0 (diff)
protobuf-c: fix host build on GCC4
prereq-build.mk says that GCC 4.8 and above is supported. GCC 4.8 does not default to gnu++11. This fixes compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/protobuf-c/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/libs/protobuf-c/Makefile b/libs/protobuf-c/Makefile
index 0a54ea2a6..42d48269d 100644
--- a/libs/protobuf-c/Makefile
+++ b/libs/protobuf-c/Makefile
@@ -48,6 +48,7 @@ endef
CMAKE_HOST_OPTIONS += \
-DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_CXX_STANDARD=11 \
-DCMAKE_SKIP_RPATH=OFF \
-DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"