aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2018-06-08 20:20:07 -0400
committerW. Michael Petullo <mike@flyn.org>2018-06-10 15:28:50 -0400
commit4944e64765354ebf1fbd4e6cb958d8fd75d42b9c (patch)
treeaa1d9b416209f7df1453cd38748702f2883788c2
parent70abc9e56b2a96ef1a8086b5f39df4171db6de5c (diff)
dovecot: update to 2.3.1
Signed-off-by: W. Michael Petullo <mike@flyn.org>
-rw-r--r--mail/dovecot/Makefile8
-rw-r--r--mail/dovecot/patches/001-configure_in.patch137
2 files changed, 96 insertions, 49 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 458345089..96fdce8e1 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dovecot
-PKG_VERSION:=2.2.35
+PKG_VERSION:=2.3.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.dovecot.org/releases/2.2
-PKG_HASH:=cce15db2fc5233386b63a3cf21c465c09e6e55014ed66c4f184b7d221a47180c
+PKG_SOURCE_URL:=https://www.dovecot.org/releases/2.3
+PKG_HASH:=0883821b97fd02a084a84b9469a681f7e6edc56541d854b5419d98891c51fb93
PKG_LICENSE:=LGPL-2.1 MIT BSD-3-Clause Unique
PKG_LICENSE_FILES:=COPYING COPYING.LGPL COPYING.MIT
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
@@ -37,7 +37,7 @@ define Package/dovecot
CATEGORY:=Mail
DEPENDS:=+DOVECOT_GSSAPI:krb5-libs +DOVECOT_LDAP:libopenldap +DOVECOT_MYSQL:libmysqlclient +DOVECOT_PGSQL:libpq +DOVECOT_SQLITE:libsqlite3 +libopenssl +librt +zlib +libbz2 +libcap +DOVECOT_ICU:icu
TITLE:=An IMAP and POP3 daemon
- URL:=http://www.dovecot.org/
+ URL:=https://www.dovecot.org/
USERID:=dovecot=59:dovecot=59
ABI_VERSION:=$(PKG_VERSION)
endef
diff --git a/mail/dovecot/patches/001-configure_in.patch b/mail/dovecot/patches/001-configure_in.patch
index a2869d126..650c5c625 100644
--- a/mail/dovecot/patches/001-configure_in.patch
+++ b/mail/dovecot/patches/001-configure_in.patch
@@ -1,49 +1,96 @@
-diff -u --recursive dovecot-2.2.35-vanilla/configure.ac dovecot-2.2.35/configure.ac
---- dovecot-2.2.35-vanilla/configure.ac 2018-03-19 08:22:42.000000000 -0400
-+++ dovecot-2.2.35/configure.ac 2018-05-25 10:41:36.122503480 -0400
-@@ -490,9 +490,10 @@
-
- if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then
- AC_CACHE_CHECK([whether we can use epoll],i_cv_epoll_works,[
+diff -u --recursive dovecot-2.3.1-vanilla/m4/fd_passing.m4 dovecot-2.3.1/m4/fd_passing.m4
+--- dovecot-2.3.1-vanilla/m4/fd_passing.m4 2018-06-08 20:02:15.849850956 -0400
++++ dovecot-2.3.1/m4/fd_passing.m4 2018-06-08 20:04:28.947016370 -0400
+@@ -8,7 +8,7 @@
+ CFLAGS="$CFLAGS -DBUGGY_CMSG_MACROS"
+ fi
+
+- AC_TRY_RUN([
++ AC_TRY_LINK([
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/wait.h>
+@@ -16,7 +16,7 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include "fdpass.h"
+-
++ ], [
+ static
+ int nopen(void)
+ {
+diff -u --recursive dovecot-2.3.1-vanilla/m4/glibc.m4 dovecot-2.3.1/m4/glibc.m4
+--- dovecot-2.3.1-vanilla/m4/glibc.m4 2018-06-08 20:02:15.850850957 -0400
++++ dovecot-2.3.1/m4/glibc.m4 2018-06-08 20:04:00.780981363 -0400
+@@ -17,7 +17,7 @@
+ dnl * Old glibcs have broken posix_fallocate(). Make sure not to use it.
+ dnl * It may also be broken in AIX.
+ AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
- AC_TRY_RUN([
+ AC_TRY_LINK([
- #include <sys/epoll.h>
+ #define _XOPEN_SOURCE 600
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -26,6 +26,7 @@
+ #if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7)
+ possibly broken posix_fallocate
+ #endif
++ ], [
+ int main() {
+ int fd = creat("conftest.temp", 0600);
+ int ret;
+diff -u --recursive dovecot-2.3.1-vanilla/m4/ioloop.m4 dovecot-2.3.1/m4/ioloop.m4
+--- dovecot-2.3.1-vanilla/m4/ioloop.m4 2018-06-08 20:02:15.850850957 -0400
++++ dovecot-2.3.1/m4/ioloop.m4 2018-06-08 20:03:31.666945181 -0400
+@@ -4,9 +4,9 @@
+ if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then
+ AC_CACHE_CHECK([whether we can use epoll],i_cv_epoll_works,[
+- AC_TRY_RUN([
++ AC_TRY_LINK([
+ #include <sys/epoll.h>
+-
++ ], [
+ int main()
+ {
+ return epoll_create(5) < 1;
+diff -u --recursive dovecot-2.3.1-vanilla/m4/mmap_write.m4 dovecot-2.3.1/m4/mmap_write.m4
+--- dovecot-2.3.1-vanilla/m4/mmap_write.m4 2018-06-08 20:02:15.850850957 -0400
++++ dovecot-2.3.1/m4/mmap_write.m4 2018-06-08 20:03:27.369939841 -0400
+@@ -1,7 +1,7 @@
+ dnl * If mmap() plays nicely with write()
+ AC_DEFUN([DOVECOT_MMAP_WRITE], [
+ AC_CACHE_CHECK([whether shared mmaps get updated by write()s],i_cv_mmap_plays_with_write,[
+- AC_TRY_RUN([
++ AC_TRY_LINK([
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+@@ -9,6 +9,7 @@
+ #include <fcntl.h>
+ #include <sys/mman.h>
+ #include <string.h>
+ ], [
- int main()
- {
- return epoll_create(5) < 1;
-@@ -596,7 +597,7 @@
- dnl * Old glibcs have broken posix_fallocate(). Make sure not to use it.
- dnl * It may also be broken in AIX.
- AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
-- AC_TRY_RUN([
-+ AC_TRY_LINK([
- #define _XOPEN_SOURCE 600
- #include <stdio.h>
- #include <stdlib.h>
-@@ -605,6 +606,7 @@
- #if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7)
- possibly broken posix_fallocate
- #endif
-+ ], [
- int main() {
- int fd = creat("conftest.temp", 0600);
- int ret;
-@@ -2059,7 +2061,7 @@
-
- # does the kerberos library support SPNEGO?
- AC_CACHE_CHECK([whether GSSAPI supports SPNEGO],i_cv_gssapi_spnego,[
-- AC_TRY_RUN([
-+ AC_TRY_LINK([
- #ifdef HAVE_GSSAPI_H
- # include <gssapi.h>
- #else
-@@ -2067,6 +2069,7 @@
- #endif
- #include <krb5.h>
- #include <string.h>
-+ ], [
- int main(void) {
- OM_uint32 minor_status;
- gss_OID_set mech_set;
+ int main() {
+ /* return 0 if we're signed */
+ int f = open("conftest.mmap", O_RDWR|O_CREAT|O_TRUNC, 0600);
+diff -u --recursive dovecot-2.3.1-vanilla/m4/want_gssapi.m4 dovecot-2.3.1/m4/want_gssapi.m4
+--- dovecot-2.3.1-vanilla/m4/want_gssapi.m4 2018-06-08 20:02:15.850850957 -0400
++++ dovecot-2.3.1/m4/want_gssapi.m4 2018-06-08 20:04:13.204996804 -0400
+@@ -54,7 +54,7 @@
+
+ # does the kerberos library support SPNEGO?
+ AC_CACHE_CHECK([whether GSSAPI supports SPNEGO],i_cv_gssapi_spnego,[
+- AC_TRY_RUN([
++ AC_TRY_LINK([
+ #ifdef HAVE_GSSAPI_H
+ # include <gssapi.h>
+ #else
+@@ -62,6 +62,7 @@
+ #endif
+ #include <krb5.h>
+ #include <string.h>
++ ], [
+ int main(void) {
+ OM_uint32 minor_status;
+ gss_OID_set mech_set;