aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-19 22:49:27 -0700
committerRosen Penev <rosenp@gmail.com>2020-06-19 23:16:33 -0700
commit483193925585ec6af8898c5a36e148571a2b42ba (patch)
tree58c22683348c021c590de4e35a6d7007454b9fb4
parent38ea3e84f8c127f38ed4a2cdb1ee0f5d0b3848f9 (diff)
libimobiledevice: update to 1.3.0
Upstream created proper tarballs. Switch to those. Removed autoreconf as a result. Adjusted filepaths. Removed upstreamed patch. Disabled static libraries as they're not useful. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/libimobiledevice/Makefile20
-rw-r--r--libs/libimobiledevice/patches/010-format.patch69
2 files changed, 10 insertions, 79 deletions
diff --git a/libs/libimobiledevice/Makefile b/libs/libimobiledevice/Makefile
index 8c12e7861..84a56ccec 100644
--- a/libs/libimobiledevice/Makefile
+++ b/libs/libimobiledevice/Makefile
@@ -8,19 +8,17 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libimobiledevice
-PKG_SOURCE_DATE:=2020-02-19
-PKG_SOURCE_VERSION:=3d8d13f0a70cefc1b12571b7f6aa2d1d4c58cffb
+PKG_VERSION:=1.3.0
PKG_RELEASE:=1
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/libimobiledevice/libimobiledevice
-PKG_MIRROR_HASH:=4239f90c68ecd250a900b5256eafc364c658dcb8cc7767c58bd59b6d6b249d4e
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://www.libimobiledevice.org/downloads
+PKG_HASH:=53f2640c6365cd9f302a6248f531822dc94a6cced3f17128d4479a77bd75b0f6
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=COPYING.LESSER
-PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
@@ -64,20 +62,22 @@ define Package/libimobiledevice-utils/description
This package contains the libimobiledevice utilities.
endef
-CONFIGURE_ARGS += --without-cython
+CONFIGURE_ARGS += \
+ --disable-static \
+ --without-cython
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/libimobiledevice $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libimobiledevice.{a,la,so*} $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libimobiledevice-1.0.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libimobiledevice-*.pc $(1)/usr/lib/pkgconfig/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libimobiledevice-1.0.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libimobiledevice/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libimobiledevice.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libimobiledevice-1.0.so.* $(1)/usr/lib/
endef
define Package/libimobiledevice-utils/install
diff --git a/libs/libimobiledevice/patches/010-format.patch b/libs/libimobiledevice/patches/010-format.patch
deleted file mode 100644
index 26ec21eeb..000000000
--- a/libs/libimobiledevice/patches/010-format.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From ec2bba4ffe5a0939ba192b014ba594eaa964412f Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Sun, 8 Dec 2019 15:45:19 -0800
-Subject: [PATCH] idevicedate: Fix -Wformat=2 warning
-
-Format functions expect a constant expression, not a variable.
-
-Simplified the code slightly.
----
- tools/idevicedate.c | 17 ++++-------------
- 1 file changed, 4 insertions(+), 13 deletions(-)
-
-diff --git a/tools/idevicedate.c b/tools/idevicedate.c
-index 4de90b63..6dddc185 100644
---- a/tools/idevicedate.c
-+++ b/tools/idevicedate.c
-@@ -38,9 +38,9 @@
- #include <libimobiledevice/lockdown.h>
-
- #ifdef _DATE_FMT
--#define DATE_FMT_LANGINFO() nl_langinfo (_DATE_FMT)
-+#define DATE_FMT_LANGINFO nl_langinfo (_DATE_FMT)
- #else
--#define DATE_FMT_LANGINFO() ""
-+#define DATE_FMT_LANGINFO "%a %b %e %H:%M:%S %Z %Y"
- #endif
-
- static void print_usage(int argc, char **argv)
-@@ -75,7 +75,6 @@ int main(int argc, char *argv[])
- uint64_t datetime = 0;
- time_t rawtime;
- struct tm * tmp;
-- char const *format = NULL;
- char buffer[80];
- int result = 0;
-
-@@ -131,14 +130,6 @@ int main(int argc, char *argv[])
- }
- }
-
-- /* determine a date format */
-- if (!format) {
-- format = DATE_FMT_LANGINFO ();
-- if (!*format) {
-- format = "%a %b %e %H:%M:%S %Z %Y";
-- }
-- }
--
- ret = idevice_new(&device, udid);
- if (ret != IDEVICE_E_SUCCESS) {
- if (udid) {
-@@ -195,7 +186,7 @@ int main(int argc, char *argv[])
- tmp = localtime(&rawtime);
-
- /* finally we format and print the current date */
-- strftime(buffer, 80, format, tmp);
-+ strftime(buffer, 80, DATE_FMT_LANGINFO, tmp);
- puts(buffer);
- } else {
- datetime = setdate;
-@@ -217,7 +208,7 @@ int main(int argc, char *argv[])
-
- if(lockdownd_set_value(client, NULL, "TimeIntervalSince1970", node) == LOCKDOWN_E_SUCCESS) {
- tmp = localtime(&setdate);
-- strftime(buffer, 80, format, tmp);
-+ strftime(buffer, 80, DATE_FMT_LANGINFO, tmp);
- puts(buffer);
- } else {
- printf("ERROR: Failed to set date on device.\n");