aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Rauta <oskari.rauta@gmail.com>2021-03-29 18:02:11 +0300
committerDaniel Golle <daniel@makrotopia.org>2021-03-29 15:16:13 +0100
commit463227f70cc75579a93a59c09cb6b372c48c13cc (patch)
treeff5bccf4298aee31f453fa5cc3c0be090629fca3
parentd424d19b5a46c2a77b20d936880144e1cdeca5ba (diff)
conmon: fix segfault, correct a typo and update description
Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
-rw-r--r--utils/conmon/Makefile8
-rw-r--r--utils/conmon/patches/100-fix-null-socket-connection-list.patch22
2 files changed, 28 insertions, 2 deletions
diff --git a/utils/conmon/Makefile b/utils/conmon/Makefile
index ad1bd26c8..198ce2e82 100644
--- a/utils/conmon/Makefile
+++ b/utils/conmon/Makefile
@@ -21,13 +21,17 @@ include ../../devel/meson/meson.mk
define Package/conmon
SECTION:=utils
CATEGORY:=Utilities
- TITLE:=Podmon conmon
+ TITLE:=Podman conmon
URL:=https://podman.io
DEPENDS:=+glib2 $(INTL_DEPENDS) $(ICONV_DEPENDS)
endef
define Package/conmon/description
- Podman: A tool for managing OCI containers and pods
+ An OCI container runtime monitor.
+
+ Conmon is a monitoring program and communication tool between
+ a container manager (like Podman or CRI-O) and an OCI runtime
+ (like runc or crun) for a single container.
endef
define Package/conmon/install
diff --git a/utils/conmon/patches/100-fix-null-socket-connection-list.patch b/utils/conmon/patches/100-fix-null-socket-connection-list.patch
new file mode 100644
index 000000000..886e13a37
--- /dev/null
+++ b/utils/conmon/patches/100-fix-null-socket-connection-list.patch
@@ -0,0 +1,22 @@
+--- a/src/conn_sock.c
++++ b/src/conn_sock.c
+@@ -465,6 +465,9 @@ static void init_remote_sock(struct remo
+
+ static void close_sock(gpointer data, G_GNUC_UNUSED gpointer user_data)
+ {
++ if (data == NULL)
++ return;
++
+ struct remote_sock_s *sock = (struct remote_sock_s *)data;
+
+ close(sock->fd);
+@@ -473,5 +476,9 @@ static void close_sock(gpointer data, G_
+
+ void close_all_readers()
+ {
++
++ if (local_mainfd_stdin.readers == NULL)
++ return;
++
+ g_ptr_array_foreach(local_mainfd_stdin.readers, close_sock, NULL);
+ }