aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-02-10 22:37:26 -0800
committerGitHub <noreply@github.com>2020-02-10 22:37:26 -0800
commit43fd0476529fa1eae4f824d55018267f03f68ce3 (patch)
tree01167b999ee0519a313f430bf4f61b8f12a5797a
parent8efc05834f3143f28fc01d2186f989e081f08347 (diff)
parent155b81547ff97f1d0f29169c2145e99f34bf0716 (diff)
Merge pull request #11301 from zhaojh329/rtty
rtty: update to 7.1.1
-rw-r--r--utils/rtty/Makefile6
-rw-r--r--utils/rtty/files/rtty.config1
-rw-r--r--utils/rtty/files/rtty.init14
3 files changed, 10 insertions, 11 deletions
diff --git a/utils/rtty/Makefile b/utils/rtty/Makefile
index e119b765d..4b6a536cd 100644
--- a/utils/rtty/Makefile
+++ b/utils/rtty/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rtty
-PKG_VERSION:=7.1.0
-PKG_RELEASE:=1
+PKG_VERSION:=7.1.1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL=https://github.com/zhaojh329/rtty/releases/download/v$(PKG_VERSION)
-PKG_HASH:=7e3910f0d9d68f1792d445de6b08c740dc4af53258275dc8294aa2d18b455bec
+PKG_HASH:=05cc5fcf126041f3bc79d92123ff2a19da25806f77fc12286498ee85da139a74
CMAKE_INSTALL:=1
PKG_LICENSE:=MIT
diff --git a/utils/rtty/files/rtty.config b/utils/rtty/files/rtty.config
index 4b9cf51bf..b9952ce1d 100644
--- a/utils/rtty/files/rtty.config
+++ b/utils/rtty/files/rtty.config
@@ -11,3 +11,4 @@
# option port '5912' # Server Port
# option ssl 1 # Whether to use ssl
# option token 'your-token' # generated by rttys
+# option verbose '1' # verbose log
diff --git a/utils/rtty/files/rtty.init b/utils/rtty/files/rtty.init
index 297f393c2..94b4c364b 100644
--- a/utils/rtty/files/rtty.init
+++ b/utils/rtty/files/rtty.init
@@ -13,7 +13,8 @@ validate_rtty_section() {
'host:host' \
'port:port' \
'ssl:bool:0' \
- 'token:maxlength(32)'
+ 'token:maxlength(32)' \
+ 'verbose:bool:0'
}
start_rtty() {
@@ -38,20 +39,17 @@ start_rtty() {
return 1
}
- [ -z "$port" ] && {
- echo "port required" >&2
- return 1
- }
-
[ -z "$id" ] && {
- id=$(cat /sys/class/net/$ifname/address | sed 's/://g' | tr 'a-z' 'A-Z')
+ id=$(sed 's/://g' /sys/class/net/$ifname/address | tr 'a-z' 'A-Z')
}
procd_open_instance
- procd_set_param command $BIN -h $host -p $port -I "$id" -a
+ procd_set_param command $BIN -h $host -I "$id" -a
+ [ -n "$port" ] && procd_append_param command -p "$port"
[ -n "$description" ] && procd_append_param command -d "$description"
[ "$ssl" = "1" ] && procd_append_param command -s
[ -n "$token" ] && procd_append_param command -t "$token"
+ [ "$verbose" = "1" ] && procd_append_param command -v
procd_set_param respawn
procd_close_instance
}