aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-01-21 14:23:11 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2018-01-21 14:23:15 +0100
commit43dfd37195f9d2a8c11891f742d9a10ae9659b6f (patch)
tree3ff6f0d960c87fbc0622ead92b7f6273d278ee68
parenta8c04c98eced837ab4d4ad8001f9a165791d48fa (diff)
sipgrep: move to telephony repo
Delete sipgrep from openwrt/packages. Once done it will be put into the openwrt/telephony repo. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
-rw-r--r--net/sipgrep/Makefile48
1 files changed, 0 insertions, 48 deletions
diff --git a/net/sipgrep/Makefile b/net/sipgrep/Makefile
deleted file mode 100644
index 4329b8252..000000000
--- a/net/sipgrep/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-#
-# Copyright (C) 2016 Daniel Engberg <daniel.engberg.lists@pyret.net>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=sipgrep
-PKG_VERSION:=20160914-devel
-PKG_RELEASE:=1
-PKG_MAINTAINER:=Daniel Engberg <daniel.engberg.lists@pyret.net>
-PKG_LICENSE:=GPL-3.0
-PKG_LICENSE_FILES:=COPYING
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/sipcapture/sipgrep
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=df8a95b066569be92aa38cad01086ea595b36863
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MIRROR_HASH:=a9131ae443bdce760e3dadd83dcf115d51a894381fc18461cbe62522618418fa
-
-PKG_FIXUP:=autoreconf
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/sipgrep
- SECTION:=net
- CATEGORY:=Network
- DEPENDS:=+libpcap +libpcre +libncursesw
- TITLE:=Display and Troubleshoot SIP signaling in CLI
- URL:=https://github.com/sipcapture/sipgrep
-endef
-
-define Package/sipgrep/description
- SipGrep is a utility for displaying and troubleshooting SIP signaling.
-endef
-
-CONFIGURE_ARGS += \
- --enable-ncurses
-
-define Package/sipgrep/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/sipgrep $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,sipgrep))