aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-11 17:24:29 -0800
committerGitHub <noreply@github.com>2020-12-11 17:24:29 -0800
commit43d07a438475073907417c3095557936dc820856 (patch)
treed4957d3dbfe53ca66f8b1e596e1a0d79717b4141
parent83dec7e40d733bab1c37b40483703308cdcb3859 (diff)
parent1eff28553e0893efd96d8e10f1c6d20ec2eecdb1 (diff)
Merge pull request #14192 from neheb/i2pd
i2pd: backport upstream fix for i386
-rw-r--r--net/i2pd/Makefile2
-rw-r--r--net/i2pd/patches/010-config.patch2
-rw-r--r--net/i2pd/patches/020-x86.patch32
3 files changed, 33 insertions, 3 deletions
diff --git a/net/i2pd/Makefile b/net/i2pd/Makefile
index 2bcc74042..a16ba9150 100644
--- a/net/i2pd/Makefile
+++ b/net/i2pd/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=i2pd
PKG_VERSION:=2.35.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/PurpleI2P/i2pd/tar.gz/$(PKG_VERSION)?
diff --git a/net/i2pd/patches/010-config.patch b/net/i2pd/patches/010-config.patch
index be0584a4c..c0d9c44d5 100644
--- a/net/i2pd/patches/010-config.patch
+++ b/net/i2pd/patches/010-config.patch
@@ -1,5 +1,3 @@
-diff --git a/contrib/i2pd.conf b/contrib/i2pd.conf
-index 5ef39bc9..8d5034eb 100644
--- a/contrib/i2pd.conf
+++ b/contrib/i2pd.conf
@@ -8,12 +8,12 @@
diff --git a/net/i2pd/patches/020-x86.patch b/net/i2pd/patches/020-x86.patch
new file mode 100644
index 000000000..6e407f197
--- /dev/null
+++ b/net/i2pd/patches/020-x86.patch
@@ -0,0 +1,32 @@
+From ca3b8191510c1006d031d02c50edcf6b4f6a6e8f Mon Sep 17 00:00:00 2001
+From: R4SAS <r4sas@i2pmail.org>
+Date: Thu, 10 Dec 2020 18:32:41 +0300
+Subject: [PATCH] [avx] check ig c++ target supports AVX
+
+Signed-off-by: R4SAS <r4sas@i2pmail.org>
+---
+ libi2pd/Crypto.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/libi2pd/Crypto.cpp
++++ b/libi2pd/Crypto.cpp
+@@ -638,7 +638,7 @@ namespace crypto
+ {
+ uint64_t buf[256];
+ uint64_t hash[12]; // 96 bytes
+-#if defined(__x86_64__) || defined(__i386__)
++#if (defined(__x86_64__) || defined(__i386__)) && defined(__AVX__) // not all X86 targets supports AVX (like old Pentium, see #1600)
+ if(i2p::cpu::avx)
+ {
+ __asm__
+--- a/libi2pd/Identity.cpp
++++ b/libi2pd/Identity.cpp
+@@ -828,7 +828,7 @@ namespace data
+ XORMetric operator^(const IdentHash& key1, const IdentHash& key2)
+ {
+ XORMetric m;
+-#if defined(__x86_64__) || defined(__i386__)
++#if (defined(__x86_64__) || defined(__i386__)) && defined(__AVX__) // not all X86 targets supports AVX (like old Pentium, see #1600)
+ if(i2p::cpu::avx)
+ {
+ __asm__