aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2023-06-03 17:57:18 +0200
committerMichael Heimpold <mhei@heimpold.de>2023-08-16 21:38:54 +0200
commit43b10ad9c1c288e3bc034a1c2be3bb0bd2749634 (patch)
tree97134b91de3a7c305588a97e36eca9cc7bdf1235
parente350e8b89499a4f5de33f14d62a42fc6fd1052d5 (diff)
php8: fix linking on riscv64 platform (again)
The initial fix was done in a2e76e497. Later we could revert it with 5779ae4c5 since a global fix in gcc was deployed. But now, PHP itself applied a workaround/fix in 8.2.8, so that we now require the initial fix again. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
-rw-r--r--lang/php8/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/lang/php8/Makefile b/lang/php8/Makefile
index 263c2bdf3..b263692a0 100644
--- a/lang/php8/Makefile
+++ b/lang/php8/Makefile
@@ -94,7 +94,7 @@ endef
define Package/php8-cli
$(call Package/php8/Default)
- DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp
+ DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp +riscv64:libatomic
TITLE+= (CLI)
endef
@@ -105,7 +105,7 @@ endef
define Package/php8-cgi
$(call Package/php8/Default)
- DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp
+ DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp +riscv64:libatomic
TITLE+= (CGI & FastCGI)
endef
@@ -127,7 +127,7 @@ endef
define Package/php8-fpm
$(call Package/php8/Default)
- DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp
+ DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp +riscv64:libatomic
TITLE+= (FPM)
endef
@@ -159,6 +159,7 @@ define Package/apache-mod-php8
CATEGORY:=Network
DEPENDS+=PACKAGE_apache-mod-php8:apache \
+PACKAGE_php8-mod-intl:libstdcpp \
+ +riscv64:libatomic \
+libpcre2 +zlib
TITLE:=PHP8 module for Apache Web Server
endef
@@ -197,6 +198,9 @@ endif
ifeq ($(CONFIG_USE_MUSL),y)
TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
endif
+ifneq ($(findstring riscv64,$(CONFIG_ARCH)),)
+TARGET_LDFLAGS += -latomic
+endif
ifneq ($(SDK)$(CONFIG_PACKAGE_php8-mod-bcmath),)
CONFIGURE_ARGS+= --enable-bcmath=shared
@@ -603,6 +607,8 @@ define BuildModule
define Package/php8-mod-$(1)
$(call Package/php8/Default)
+ DEPENDS+=+riscv64:libatomic
+
ifneq ($(3),)
DEPENDS+=$(3)
endif