aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-12-26 08:54:49 -0800
committerRosen Penev <rosenp@gmail.com>2018-12-26 11:11:02 -0800
commit433f882cd679c700e67340102f7026c87aec29cd (patch)
tree517f5312f700433b01166e9abade873ab9df501e
parent596f8dc5e9ccdb67f1ae92b248b5da2e9164532a (diff)
libpfring: Update to 7.4.0
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/libpfring/Makefile7
-rw-r--r--libs/libpfring/patches/0001-fix-cross-compiling.patch8
-rw-r--r--libs/libpfring/patches/0002-fix-march-native.patch12
-rw-r--r--libs/libpfring/patches/0003-fix-strncpy.patch10
-rw-r--r--libs/libpfring/patches/010-fix-buildbots.patch10
5 files changed, 8 insertions, 39 deletions
diff --git a/libs/libpfring/Makefile b/libs/libpfring/Makefile
index 1da4e4e70..2a0a94c6c 100644
--- a/libs/libpfring/Makefile
+++ b/libs/libpfring/Makefile
@@ -8,16 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libpfring
-PKG_VERSION:=7.2.0
-PKG_RELEASE:=2
+PKG_VERSION:=7.4.0
+PKG_RELEASE:=1
PKG_MAINTAINER:=Banglang Huang <banglang.huang@foxmail.com>
PKG_LICENSE:=LGPL-2.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/ntop/PF_RING/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=5d349ac37a6ece5966bf606a6f131d628b98d88654c2f502d3c4b8bbf6ef9796
-
+PKG_HASH:=e1c9cb44d8072854220f493c56fa5cba99a6b8336883939dc18b3e30c2954b68
PKG_BUILD_DIR:=$(BUILD_DIR)/PF_RING-$(PKG_VERSION)
PKG_INSTALL:=1
diff --git a/libs/libpfring/patches/0001-fix-cross-compiling.patch b/libs/libpfring/patches/0001-fix-cross-compiling.patch
index 5af3fb9d5..6cfc6af3b 100644
--- a/libs/libpfring/patches/0001-fix-cross-compiling.patch
+++ b/libs/libpfring/patches/0001-fix-cross-compiling.patch
@@ -1,7 +1,7 @@
--- a/userland/configure
+++ b/userland/configure
-@@ -3745,12 +3745,6 @@ fi
- if test "$IS_FREEBSD" != "1"; then
+@@ -3718,12 +3718,6 @@ fi
+ if test "$IS_FREEBSD" != "1" && test "$cross_compiling" != "yes" ; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if r/w locks are supported" >&5
$as_echo_n "checking if r/w locks are supported... " >&6; }
- if test "$cross_compiling" = yes; then :
@@ -13,7 +13,7 @@
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -3763,7 +3757,7 @@ else
+@@ -3736,7 +3730,7 @@ else
_ACEOF
@@ -22,7 +22,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
cat >>confdefs.h <<_ACEOF
-@@ -3777,7 +3771,6 @@ $as_echo "no" >&6; }
+@@ -3750,7 +3744,6 @@ $as_echo "no" >&6; }
fi
rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext \
conftest.$ac_objext conftest.beam conftest.$ac_ext
diff --git a/libs/libpfring/patches/0002-fix-march-native.patch b/libs/libpfring/patches/0002-fix-march-native.patch
index 69bfde713..b8d6595d8 100644
--- a/libs/libpfring/patches/0002-fix-march-native.patch
+++ b/libs/libpfring/patches/0002-fix-march-native.patch
@@ -1,16 +1,6 @@
--- a/userland/configure
+++ b/userland/configure
-@@ -3296,14 +3296,16 @@ fi
- done
-
-
--MACHINE=`uname -m`
-+if test -z "$MACHINE"; then
-+ MACHINE=`uname -m`
-+fi
- CFLAGS=""
- SYS_LIBS=""
-
+@@ -3291,7 +3291,7 @@ SYS_LIBS=""
VER=`cat ../kernel/linux/pf_ring.h | grep RING_VERSION | head -1 | cut -d '"' -f 2`
MAJOR_VER=`cat ../kernel/linux/pf_ring.h | grep RING_VERSION | head -1 | cut -d '"' -f 2 | cut -d '.' -f 1`
diff --git a/libs/libpfring/patches/0003-fix-strncpy.patch b/libs/libpfring/patches/0003-fix-strncpy.patch
deleted file mode 100644
index f42c4e524..000000000
--- a/libs/libpfring/patches/0003-fix-strncpy.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/userland/lib/pfring_mod.c
-+++ b/userland/lib/pfring_mod.c
-@@ -24,6 +24,7 @@
- #include <ifaddrs.h>
-
- #ifdef ENABLE_BPF
-+#include <string.h>
- #include <pcap/pcap.h>
- #include <pcap/bpf.h>
- #include <pcap-int.h>
diff --git a/libs/libpfring/patches/010-fix-buildbots.patch b/libs/libpfring/patches/010-fix-buildbots.patch
deleted file mode 100644
index f5f153e9d..000000000
--- a/libs/libpfring/patches/010-fix-buildbots.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/userland/nbpf/Makefile.in b/userland/nbpf/Makefile.in
-index b0d8181..8221e41 100644
---- a/userland/nbpf/Makefile.in
-+++ b/userland/nbpf/Makefile.in
-@@ -1,4 +1,4 @@
--LEX = lex
-+LEX = flex
- YACC = bison
- INCLUDE = -I../lib -I../../kernel
- LIBS=`../lib/pfring_config --libs` -lpthread #@NDPI_LIB@