aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Randolf <br1@einfach.org>2018-09-26 12:27:27 +0100
committerKarl Palsson <karlp@tweak.net.au>2018-10-28 19:57:08 +0000
commit42fdfe14a0a9defa95836682e745eec47a215265 (patch)
treeebab6b7a8095d4bca1887f23bae531ccdc0bfeda
parent2f8eb41827b63aed510b71cbf5baf73eaa0efe6b (diff)
websocketpp: Add package (WebSocket++)
WebSocket++ is a header only C++ library that implements RFC6455 The WebSocket Protocol. Signed-off-by: Bruno Randolf <br1@einfach.org>
-rw-r--r--libs/websocketpp/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/libs/websocketpp/Makefile b/libs/websocketpp/Makefile
new file mode 100644
index 000000000..697957384
--- /dev/null
+++ b/libs/websocketpp/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2018 Bruno Randolf (br1@einfach.org)
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=websocketpp
+PKG_VERSION:=0.8.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/zaphoyd/websocketpp/archive/$(PKG_VERSION)/
+PKG_HASH:=178899de48c02853b55b1ea8681599641cedcdfce59e56beaff3dd0874bf0286
+
+PKG_MAINTAINER:=Bruno Randolf <br1@einfach.org>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_INSTALL:=1
+
+define Package/websocketpp
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=WebSocket++
+ URL:=https://www.zaphoyd.com/websocketpp
+endef
+
+define Package/websocketpp/description
+ WebSocket++ is a header only C++ library that implements RFC6455
+ The WebSocket Protocol.
+endef
+
+$(eval $(call BuildPackage,websocketpp))