aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Walsh <andy.walsh44+github@gmail.com>2019-12-13 17:15:42 +0100
committerAndy Walsh <andy.walsh44+github@gmail.com>2019-12-13 17:15:42 +0100
commit42e9057d41f9d59916daa9d716734f25a666b55a (patch)
tree0304cca0ef869e1a45ecd219786bbec4619fe0ea
parentb2a890f6adb9014a6db38c0b4231c42598a8512d (diff)
libtasn1: add host-build
* samba4 complains that it cant find the libasn1 host bins Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
-rw-r--r--libs/libtasn1/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/libs/libtasn1/Makefile b/libs/libtasn1/Makefile
index 73afadca9..225126056 100644
--- a/libs/libtasn1/Makefile
+++ b/libs/libtasn1/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libtasn1
PKG_VERSION:=4.15.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
@@ -25,6 +25,7 @@ PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define Package/libtasn1
SECTION:=libs
@@ -48,7 +49,8 @@ CONFIGURE_ARGS += \
--disable-valgrind-tests
define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/bin
+ # $(INSTALL_DIR) $(1)/usr/bin
+ # $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/libtasn1.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
@@ -62,4 +64,5 @@ define Package/libtasn1/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtasn1.so.* $(1)/usr/lib/
endef
+$(eval $(call HostBuild))
$(eval $(call BuildPackage,libtasn1))