aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-05-02 20:27:48 -0700
committerRosen Penev <rosenp@gmail.com>2019-05-16 13:32:54 -0700
commit4108353ec15ee197cc42d29859ddc09e147b72bb (patch)
tree53671e01d12ce0e0d18eed1d49d980582928e09a
parentfc6b32c7d983a86532f1fc88933cad7bc7aeb055 (diff)
port-mirroring: Fix compilation with GCC8
Signed-off-by: Rosen Penev <rosenp@gmail.com>
2 files changed, 21 insertions, 1 deletions
diff --git a/net/port-mirroring/Makefile b/net/port-mirroring/Makefile
index 6c32174ee..a001e47ed 100644
--- a/net/port-mirroring/Makefile
+++ b/net/port-mirroring/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=port-mirroring
PKG_VERSION:=1.4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/mmaraya/port-mirroring/tar.gz/v$(PKG_VERSION)?
diff --git a/net/port-mirroring/patches/010-snprintf-to-strncpy.patch b/net/port-mirroring/patches/010-snprintf-to-strncpy.patch
new file mode 100644
index 000000000..d28c2e23a
--- /dev/null
+++ b/net/port-mirroring/patches/010-snprintf-to-strncpy.patch
@@ -0,0 +1,20 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -90,7 +90,7 @@ int loadCfg(const char *fpath)
+ }
+ else
+ {
+- snprintf(cfg.dst_if, IFNAMSIZ, "%s", value);
++ strncpy(cfg.dst_if, value, IFNAMSIZ);
+ cfg.flags |= PM_DST_IF;
+ }
+ }
+@@ -104,7 +104,7 @@ int loadCfg(const char *fpath)
+ }
+ else if (strcmp(option, "filter") == 0)
+ {
+- snprintf(cfg.pfe, PFE_MAX, "%s", value);
++ strncpy(cfg.pfe, value, PFE_MAX);
+ }
+ else if (strcmp(option, "promiscuous") == 0)
+ {