aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2016-01-08 22:59:06 +0100
committerMichael Heimpold <mhei@heimpold.de>2016-01-08 22:59:06 +0100
commit40d611c673aa397048b84ef55518c751124205a7 (patch)
tree1c6d91bba72307cee7ac758506ffa3ec77c108f2
parent48f1406b18b33f2b70ca00bed0dd3d4204845bf9 (diff)
devel/pkg-config: fix build when CONFIG_BUILD_NLS is set
Buildbots reported build failures when full NLS is enabled: http://buildbot.openwrt.org:8010/broken_packages/ar71xx/pkg-config/compile.txt So add NLS awareness and the conditional dependency. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
-rw-r--r--devel/pkg-config/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/pkg-config/Makefile b/devel/pkg-config/Makefile
index beb0a94c0..36abc5dc1 100644
--- a/devel/pkg-config/Makefile
+++ b/devel/pkg-config/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pkg-config
PKG_VERSION:=0.29
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -20,13 +20,14 @@ PKG_LICENSE:=GPL-2+
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
define Package/pkg-config
SECTION:=devel
CATEGORY:=Development
TITLE:=pkg-config
URL:=http://www.freedesktop.org/wiki/Software/pkg-config/
- DEPENDS:=+glib2
+ DEPENDS:=+glib2 $(INTL_DEPENDS)
endef
define Package/pkg-config/description