aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Baier <jan.baier@amagical.net>2021-08-18 14:19:10 +0200
committerEtienne Champetier <champetier.etienne@gmail.com>2021-09-08 17:13:52 -0400
commit3fa342d2f0bd2895e6f39796bcba13fd842d8fd6 (patch)
treea6f71627367b61d90854e99c8db5dd600006e8d7
parentada9d25ef7d2466cd62165ab38cfa6e8f574f83b (diff)
vpn-policy-routing: Call killall with the -s
Some versions of killall do support the `killall -SIGNAL` syntax and have only `-s SIGNAL` which should be supported everywhere. I see the problem with *killall (PSmisc) 23.3* on latest TurrisOS 5.2 Signed-off-by: Jan Baier <jan.baier@amagical.net>
-rw-r--r--net/vpn-policy-routing/Makefile2
-rwxr-xr-xnet/vpn-policy-routing/files/vpn-policy-routing.init2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/vpn-policy-routing/Makefile b/net/vpn-policy-routing/Makefile
index d1476bbc4..202ee24de 100644
--- a/net/vpn-policy-routing/Makefile
+++ b/net/vpn-policy-routing/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=vpn-policy-routing
PKG_VERSION:=0.3.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
diff --git a/net/vpn-policy-routing/files/vpn-policy-routing.init b/net/vpn-policy-routing/files/vpn-policy-routing.init
index b15b1af49..89c8f75f3 100755
--- a/net/vpn-policy-routing/files/vpn-policy-routing.init
+++ b/net/vpn-policy-routing/files/vpn-policy-routing.init
@@ -154,7 +154,7 @@ is_domain() { str_contains "$1" '[a-zA-Z]'; }
is_phys_dev() { [ "${1:0:1}" = "@" ] && ip l show | grep -E -q "^\\d+\\W+${1:1}"; }
is_turris() { /bin/ubus -S call system board | /bin/grep 'Turris' | /bin/grep -q '15.05'; }
is_chaos_calmer() { ubus -S call system board | grep -q 'Chaos Calmer'; }
-dnsmasq_kill() { killall -q -HUP dnsmasq; }
+dnsmasq_kill() { killall -q -s HUP dnsmasq; }
dnsmasq_restart() { output 3 'Restarting DNSMASQ '; if /etc/init.d/dnsmasq restart >/dev/null 2>&1; then output_okn; else output_failn; fi; }
is_default_dev() { [ "$1" = "$(ip -4 r | grep -m1 'dev' | grep -Eso 'dev [^ ]*' | awk '{print $2}')" ]; }
is_supported_iface_dev() {