aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-06-02 03:50:00 +0200
committerDavid Bauer <mail@david-bauer.net>2023-10-08 23:11:29 +0200
commit3f7f33d8becb188436d711671f7cd111a603add2 (patch)
tree486ff514a24a6679b1d3710bf5c1f07173a128bd
parent597df3585fae16ac1e8a64b839c7159a907e70af (diff)
cudy-bdinfo: add package
This program can be used to obtain information stored on the bdinfo parition found on routers from Shenzhen Cudy Technology. While this tool is not necessary for operation with OpenWrt, it can be helpful to decrypt information generated by the stock firmware as well as to obtain additional device-specific information. Signed-off-by: David Bauer <mail@david-bauer.net>
-rw-r--r--utils/cudy-bdinfo/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/utils/cudy-bdinfo/Makefile b/utils/cudy-bdinfo/Makefile
new file mode 100644
index 000000000..7d56ffbfe
--- /dev/null
+++ b/utils/cudy-bdinfo/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2023 David Bauer <mail@david-bauer.net>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cudy-bdinfo
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/blocktrron/cudy-bdinfo-decrypt.git
+PKG_SOURCE_DATE:=2023-06-01
+PKG_SOURCE_VERSION:=5a60308c0fff610c4698207387d7153aba5fd62b
+PKG_MIRROR_HASH:=aefcd37e4b059d92226d2bc97b1b199f6a360c4935a6e92c930998b510275838
+
+PKG_MAINTAINER:=David Bauer <mail@david-bauer.net>
+PKG_LICENSE:=GPL-2.0-or-later
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/cudy-bdinfo
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=@(TARGET_ramips||TARGET_mediatek) +libopenssl
+ TITLE:=Tool for reading the bdinfo partition of Cudy routers
+endef
+
+define Package/cudy-bdinfo/description
+This program can be used to obtain information stored on the
+bdinfo parition found on routers from Shenzhen Cudy Technology.
+endef
+
+define Package/cudy-bdinfo/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/cudy-bdinfo $(1)/usr/bin/cudy-bdinfo
+endef
+
+
+$(eval $(call BuildPackage,cudy-bdinfo))