aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2017-01-06 07:55:01 -0500
committerW. Michael Petullo <mike@flyn.org>2017-01-06 07:55:01 -0500
commit3cc1cf80232853e3dd12bf91e8135cef5270d6fd (patch)
tree43a6c9e144e3b41c7c12944cc7007c63fe90537d
parent74e436fac5dc5f15020eb6b7c30d557600a13c27 (diff)
eventlog: import from oldpackages
Signed-off-by: W. Michael Petullo <mike@flyn.org>
-rw-r--r--libs/eventlog/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/libs/eventlog/Makefile b/libs/eventlog/Makefile
new file mode 100644
index 000000000..d0658ff97
--- /dev/null
+++ b/libs/eventlog/Makefile
@@ -0,0 +1,44 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=eventlog
+PKG_VERSION:=0.2.12
+PKG_RELEASE:=2
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_SOURCE_URL:=https://my.balabit.com/downloads/eventlog/0.2/
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=3d6ebda8a161d36cb40d09328f78786b
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libeventlog
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A new API to format and send structured log messages.
+endef
+
+define Package/eventlog/description
+ A new API to format and send structured log messages. It supports multiple message
+ representations (plain, XML attributes and XML tags) and multiple output methods
+ (local syslogd).
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/eventlog $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevtlog.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/eventlog.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libeventlog/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libevtlog.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libeventlog))