aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuintin Hill <stuff@quintin.me.uk>2023-03-10 22:49:03 +0000
committerQuintin Hill <stuff@quintin.me.uk>2023-03-20 13:32:04 +0000
commit3c6a6746b0da7f084a2f7e21c31cad6d898ecc46 (patch)
treede50edd5ecb716f8d3d82032b4f351886f5887f3
parent76b0a3c1ec7300fefbbf205cf7b97a8b04115bbf (diff)
python-dbus-fast: add package
This package is a dependency of bleak. Building and installing this package via pip on a router is not difficult and the build crashes when memory is exhausted. Signed-off-by: Quintin Hill <stuff@quintin.me.uk>
-rw-r--r--lang/python/python-dbus-fast/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/lang/python/python-dbus-fast/Makefile b/lang/python/python-dbus-fast/Makefile
new file mode 100644
index 000000000..ad6b0b40b
--- /dev/null
+++ b/lang/python/python-dbus-fast/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2023
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-dbus-fast
+PKG_VERSION:=1.84.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=dbus-fast
+PYPI_SOURCE_NAME:=dbus_fast
+PKG_HASH:=62b00b85c5835bff1d7ab5b12d494e588d92612bedbd7ca86176861729b8e4bc
+
+PKG_MAINTAINER:=Quintin Hill <stuff@quintin.me.uk>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-dbus-fast
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=A faster version of dbus-next
+ URL:=https://github.com/Bluetooth-Devices/dbus-fast
+ DEPENDS:=+python3-light +python3-async-timeout +python3-asyncio \
+ +python3-logging +python3-urllib +python3-xml
+endef
+
+define Package/python3-dbus-fast/description
+ dbus-fast is a Python library for DBus that aims to be a performant fully
+ featured high level library primarily geared towards integration of
+ applications into Linux desktop and mobile environments.
+endef
+
+$(eval $(call Py3Package,python3-dbus-fast))
+$(eval $(call BuildPackage,python3-dbus-fast))
+$(eval $(call BuildPackage,python3-dbus-fast-src))