aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-07-20 19:22:45 -0700
committerRosen Penev <rosenp@gmail.com>2019-07-20 19:22:45 -0700
commit3bceaf67dc82345446cd05b5a4a119712c36701a (patch)
treeab74de5aa3b621a4c0521a193617cede25ffa28c
parentec84a5b59c705a9a761f2ade3e91cc6684549531 (diff)
perl-device-usb: Update to 0.38
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--lang/perl-device-usb/Makefile6
-rw-r--r--lang/perl-device-usb/patches/140-avoid-libusb-name-conflicts.patch12
2 files changed, 9 insertions, 9 deletions
diff --git a/lang/perl-device-usb/Makefile b/lang/perl-device-usb/Makefile
index ac936ba12..fdee5cc8b 100644
--- a/lang/perl-device-usb/Makefile
+++ b/lang/perl-device-usb/Makefile
@@ -8,15 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-device-usb
-PKG_VERSION:=0.37
+PKG_VERSION:=0.38
PKG_RELEASE:=1
PKG_SOURCE_URL:=https://www.cpan.org/authors/id/G/GW/GWADEJ/
PKG_SOURCE:=Device-USB-$(PKG_VERSION).tar.gz
-PKG_HASH:=0dd58d9c627b3c539d07263a7b96e1de2adea3a4ddb118cdd45aa638f8702e49
+PKG_HASH:=f0c36379db4913406dc9bd546a6cfd4da20d58f7c2cc085893a2fe67a43465dc
-PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
+PKG_LICENSE:=GPL-1.0-or-later Artistic-1.0-Perl
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Device-USB-$(PKG_VERSION)
PKG_BUILD_DEPENDS:=perl-inline-c/host
diff --git a/lang/perl-device-usb/patches/140-avoid-libusb-name-conflicts.patch b/lang/perl-device-usb/patches/140-avoid-libusb-name-conflicts.patch
index 552306ec4..9ce0ba320 100644
--- a/lang/perl-device-usb/patches/140-avoid-libusb-name-conflicts.patch
+++ b/lang/perl-device-usb/patches/140-avoid-libusb-name-conflicts.patch
@@ -3,12 +3,12 @@
@@ -15,6 +15,7 @@ use Inline (
($ENV{LIBUSB_INCDIR} ? ( INC => "-I\"$ENV{LIBUSB_INCDIR}\"" ) : () ),
NAME => 'Device::USB',
- VERSION => '0.37',
+ VERSION => '0.38',
+ PREFIX => 'deviceusb_',
);
Inline->init();
-@@ -540,74 +541,74 @@ unsigned DeviceUSBDebugLevel()
+@@ -657,74 +658,74 @@ unsigned DeviceUSBDebugLevel()
return debugLevel;
}
@@ -98,7 +98,7 @@
}
#if LIBUSB_HAS_GET_DRIVER_NP
ret = usb_get_driver_np((usb_dev_handle *)dev, interface, name, namelen);
-@@ -618,11 +619,11 @@ int libusb_get_driver_np(void *dev, int
+@@ -735,11 +736,11 @@ int libusb_get_driver_np(void *dev, int interface, char *name, unsigned int name
#endif
}
@@ -112,7 +112,7 @@
}
#if LIBUSB_HAS_DETACH_KERNEL_DRIVER_NP
return usb_detach_kernel_driver_np((usb_dev_handle *)dev, interface);
-@@ -631,25 +632,25 @@ int libusb_detach_kernel_driver_np(void
+@@ -748,25 +749,25 @@ int libusb_detach_kernel_driver_np(void *dev, int interface)
#endif
}
@@ -143,7 +143,7 @@
{
int i = 0;
int retval = 0;
-@@ -658,7 +659,7 @@ void libusb_control_msg(void *dev, int r
+@@ -775,7 +776,7 @@ void libusb_control_msg(void *dev, int requesttype, int request, int value, int
if(DeviceUSBDebugLevel())
{
@@ -152,7 +152,7 @@
requesttype, request, value, index, bytes, size, timeout
);
/* maybe need to add support for printing the bytes string. */
-@@ -691,54 +692,54 @@ void libusb_control_msg(void *dev, int r
+@@ -808,54 +809,54 @@ void libusb_control_msg(void *dev, int requesttype, int request, int value, int
Inline_Stack_Done;
}