aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-03-07 13:38:07 +0800
committerJeffery To <jeffery.to@gmail.com>2023-04-24 16:20:32 +0800
commit39991fec1e42c1bed0a94e4b9dc584265d07e4f5 (patch)
tree7fb6376148141922eece5cbd517f048e9504fc01
parent4195e5c4a8dcb0dfce8049e3e61844a3c1a90d67 (diff)
i2c-tools: Prepare for new Python build process
This sets build options and adds a call to Py3Build/Install to prepare for the new Python build process. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--utils/i2c-tools/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/utils/i2c-tools/Makefile b/utils/i2c-tools/Makefile
index 8b1563c2e..f1a871dd9 100644
--- a/utils/i2c-tools/Makefile
+++ b/utils/i2c-tools/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=i2c-tools
PKG_VERSION:=4.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/utils/i2c-tools
@@ -69,6 +69,8 @@ endef
PYTHON3_PKG_SETUP_ARGS:=
PYTHON3_PKG_SETUP_DIR:=py-smbus
+PYTHON3_PKG_WHEEL_NAME:=smbus
+PYTHON3_PKG_WHEEL_VERSION:=1.1
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
@@ -86,6 +88,10 @@ define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/lib/libi2c.{a,so*} $(1)/usr/lib/
endef
+define Build/Install
+ $(call Py3Build/Install)
+endef
+
define Package/libi2c/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/libi2c.so* $(1)/usr/lib/