aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2018-03-19 15:44:20 +0100
committerJan Pavlinec <jan.pavlinec@nic.cz>2018-03-19 15:44:20 +0100
commit3916b08b3002454abdbf383f3d9d426f88e44d46 (patch)
tree6cc2d49714026ebaeaaa8b93e192c7c3360c784e
parent5d0971b9ccf85b959c7c7a57f262ca96c6d4b744 (diff)
poco: update to version 1.8.1
Fix CVE-2017-1000472 - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000472 Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
-rw-r--r--libs/poco/Makefile4
-rw-r--r--libs/poco/patches/200-strerror.patch18
2 files changed, 11 insertions, 11 deletions
diff --git a/libs/poco/Makefile b/libs/poco/Makefile
index 417f6fbc6..54041a449 100644
--- a/libs/poco/Makefile
+++ b/libs/poco/Makefile
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=poco
-PKG_VERSION:=1.7.7
+PKG_VERSION:=1.8.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://pocoproject.org/releases/$(PKG_NAME)-$(PKG_VERSION)
-PKG_HASH:=17783e30f5ef9c852544ac0e9d1fd316c4804317026059a9d6aad798b61c77f8
+PKG_HASH:=2e4c07ac73174ee06c7e2c7cf2b7642a5b3aea81d0203e1c069b32ac4a8ecfbc
PKG_LICENSE:=BSL-1.0
PKG_LICENSE_FILES:=LICENSE
diff --git a/libs/poco/patches/200-strerror.patch b/libs/poco/patches/200-strerror.patch
index 54cce519e..bd6075497 100644
--- a/libs/poco/patches/200-strerror.patch
+++ b/libs/poco/patches/200-strerror.patch
@@ -1,11 +1,11 @@
--- a/Foundation/src/Error.cpp
+++ b/Foundation/src/Error.cpp
-@@ -66,7 +66,7 @@
- without -D_GNU_SOURCE is needed, otherwise the GNU version is
- preferred.
- */
--#if defined _GNU_SOURCE && !POCO_ANDROID
-+#if (defined _GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__)) && !POCO_ANDROID
- char errmsg[256] = "";
- return std::string(strerror_r(errorCode, errmsg, 256));
- #elif (_XOPEN_SOURCE >= 600) || POCO_ANDROID
+@@ -70,7 +70,7 @@ namespace Poco {
+
+ #if (_XOPEN_SOURCE >= 600) || POCO_ANDROID || __APPLE__
+ setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
+-#elif _GNU_SOURCE
++#elif (_GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__))
+ setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
+ #else
+ setMessage(strerror(err));